Multiplayer in rooms freezes computer (Found on Animal Crossing New Leaf))

Issue:
I was playing Animal Crossing: New Leaf and decided to connect to a room so I could try the multiplayer features. When I went to the train station and attempted to find nearby towns, the game immediately froze and my computer slowed down significantly. It took a couple of minutes to get the emulator to close. I then opened the task manager and reopened the emulator. The game pushes the memory and CPU usage to 40% normally (with nothing but Discord and other background apps running), but when I tried searching for a nearby town, the CPU went up to 70%, and the memory usage started increasing gradually in increments of about 15% each. When it got to 99%, the computer just froze: mouse, audio, and all. I had to use the power button to shut it down. Tried again and had similar results.

System Information

  • Operating System:
  • CPU: Intel® Core™ i5-4310U CPU @ 2.00GHz 2.60 GHz
  • GPU: Nvidia Geforce GT 720M
  • RAM: 8 GB
  • Citra Version: 1696
  • Game: Animal Crossing New Leaf
  • Screenshot of Issue: Do you really think I want to do that again for the sake of a screenshot? Maybe tomorrow…citra_log.txt (5.2 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The log seems to display nothing much after I connected to the room

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch/ and close citra if it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.

No more need. I was using AC:NL Rev. 1, but recently converted to Welcome Amiibo, and I no longer have the issue.