Multiplayer isnt working

ive been trying to make a room so i can play kirby triple deluxe with my friends but nothing works.
we have tried looking for tutorials, creating rooms (keeps saying unable to connect to host) and we tried finding our ip and port using cmd, nothing.

You need to make sure you have port forwarded correctly in your router. If it is still not working you might be behind a NAT.

You can try using like Hamachi or ZeroTier to tunnel the connection so you won’t need to port forward. You will just need to create accounts and then create and join the same network within the program and use the provided IP instead of your real IP of whoever is going to host.

thanks for the help i will try that

same thing happens, i tried using zero tier and still the same error (unable to connect to host) and then i used hamachi but still the same error, I don’t know what to do anymore

When using Hamachi, don’t host listed, host unlisted. The others connected to the same Hamachi network can join your room using the Direct Connect to Room option under the Multiplayer tab.

still the same error man

You will need to provide screenshots since I don’t know how you are doing things.

okay tell me what to screenshot and ill screenshot it

All steps you take from connecting to like Hamachi to inserting the IP in Citra. You can use like to create an album of screenshots.