Multiplayer lobby creation problem

#1

Issue:
When i try to create a multiplayer lobby i got an error 400

System Information

  • Operating System: windows 7 64bit
  • CPU: Amd ATLHON x3
  • GPU: AMD R7 260x 2gb
  • Citra Version (found in title bar): #900
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar): citra_log.txt (6.4 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

Have you configured your username and token on Emulation > Configure > General > Web?
user name is your forum username, you can find your token here. click on ‘Verify’, those field should go green indicating success. you may need to re-open citra to create a room.

#3

Yes I did. It also show green when I verify it

#4

But still doesn’t work. Honestly I created the lobby with success just one time before #900 update and it was successfully. After restart citra and update it show that error 400 message

#5

Open the qt-config file on C:\Users\%username%\AppData\Roaming\Citra\config and look for the lines, are they the same as bellow?:

[WebService]
enable_telemetry\default=false
enable_telemetry=false
telemetry_endpoint_url\default=true
telemetry_endpoint_url=https://services.citra-emu.org/api/telemetry
verify_endpoint_url\default=true
verify_endpoint_url=https://services.citra-emu.org/api/profile
announce_multiplayer_room_endpoint_url\default=true
announce_multiplayer_room_endpoint_url=https://services.citra-emu.org/api/multiplayer/rooms
citra_username=your_username
citra_token=your token
web_services_endpoint_url\default=true
web_services_endpoint_url=https://api.citra-emu.org
web_services_url\default=true
web_services_url=https://api.citra-emu.org
web_api_url\default=true
web_api_url=https://api.citra-emu.org

#6

No isnt same and i ve really less “string” under webservice.
Mine are these.

[WebService]
enable_telemetry\default=true
enable_telemetry=true
web_api_url\default=true
web_api_url=https://api.citra-emu.org
citra_username my username (just hide the one wrote in config file)
citra_token= my token (just hide the one wrote in config file)

#7

probably left over config from old builds, i’ve regenerated the WebService field again and i have now the same fields, like yours. and it is working fine here.

restart your computer and verify if your firewall is enabled. if so, open ‘Windows Firewall with Advanced Security’ and on ‘Inbound Rules’ look for ‘citra-qt’, there should be two citra-qt profiles.

#8

i checked into firewall with advanced security but cannot find Citra-qt. I dont know why i was able to create that server just one time and then nothing.

1 Like
#9

Close citra, and on the ‘Windows Firewall with Advanced Security’, delete citra-qt entries, open citra and try again to create a room, a window firewall message will pop up, with a box already checked on “Public networks …”, click on “Allow access”.