Multiplayer not working

Issue:
Enter a description of your issue here, in full detail.
whenever I try to connect to a room it say “version mismatch! Please update to latest version of citra.If problem persists , contact the room host and ask them to update the server.”

System Information

  • Operating System: macOS Sierra 10.12.6
  • CPU: i5 2.5
  • GPU:
  • Citra Version (found in title bar): citra nightly 976
  • Game: Pokemon Ultra moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

You’ll need to update to the latest version of Citra.

I CANT INSTALL LATEST BUILD IT SAYS
Abort trap:6

logout

Saving session…

…copying shared history…

…saving history…truncating history files…

…completed.

[Process completed]