Multiplayer's not working

Issue:
For some reason, whenever I join a room, No players are showing. It acts as if I didn’t Join a room. How do I fix this?

System Information

  • Operating System:
  • CPU: Core i
  • GPU:
  • Citra Version (found in title bar): Citra Canary 2530
  • Game: Pokemon: Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):
    Uploading: image.png…

Diagnostic Log
Uploading: citra_log.txt(1)…
Processing: citra_log.txt…

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

citra_log.txt (2.8 MB)

Note: Ultra moon seems to be working, but not ultra sun.

  1. Make sure that you do not use any save states prior to joining the room.
  2. Make sure that you’re not using any cheat codes.
  3. Make sure that you and the other players are on the same game update version.

Lastly, are you sure that there are other players in the room? Does the room chat mention you joining the room successfully or not?

(Sorry to reply late) But yeah, It does. There are like 9 people on the room and It still notifies them all that I joined. It might be because of the save file, since I also have a save on ultra moon that seems to be working fine. If it is the save file, what do I do?

Hmmm, did you use any save file editors, like PKHeX?