Multiple instances Citra Crash / wont Restart / wont soft reset

Hello everyone,

I am trying to get multiple instances of Citra running at the same time to improve my Shiny soft reset hunting in Pokemon Omega Ruby, and here is the issue:

Issue:

When I open multiple instances of Citra and play multiples games at the same time, everything seems to work fine up until I decide to do any of theses actions: restart, stop, soft reset(L+R+start).
At that point, the first instance of Citra (the one that I opened first) seems perfectly fine, but all the other one will behave as follow:
When restart or stop is pressed, the Citra instance in question will crash (not responding).
When a soft reset is done (affecting all the instances at once) a black screen will be displayed on all the Citra instances (except the first one that will behave normally). Nothing else will happen until I try to launch the game again by pressing restart or select the .3ds in my game directory, causing the Citra instance to crash. Trying to close the Citra instance will also cause it to crash.

The log file uploaded below is the one of an instance that show a black screen after a soft reset.

What I have tried to solved the problem:

Duplicating the game folder so Citra do not use the same game (if this actually does anything)

Using two different Citra ID (portable Citra - two different ‘user’ directories)

Using Canary

Running Citra as administrator

System Information

  • Operating System: Win 10
  • CPU: Intel i7-7700 4.20GHz
  • GPU: ASUS Dual GTX1070
  • Citra Version (found in title bar): 1224 and 1220
  • Game: Pokemon Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):
    On this screenshot, the second Citra instance on the right is showing the black screen. Restarting the game or closing the software will cause it to crash.

Diagnostic Log

citra_log.txt (38.9 KB)

System Information for Support

Enable CPU JIT                                [x]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
Enable Vsync                                  [ ]
LLE Audio Emulation Enabled                   [ ]
Use GDB Stub                                  [ ]
System Region                                 -1
OpenGL Version                                3.3.0
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1070/PCIe/SSE2

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended for accurate emulation.

This is a known issue: