My Citra legit will not work

Enable hardware shader causes my games to crash but when it’s off, my game runs really slow. Any fixes?

System Information

  • Operating System: PC/Windows 10
  • CPU: AMD if that is what a cpu is
  • GPU: Radeon if that is what a gpu is
  • Citra Version (found in title bar): nightly 1784G
  • Game: All of my games on citra
  • Screenshot of Issue (include the full Citra window including titlebar):Whenever I try recording the problem the recording stops and deletes because my screen freezes, turns black and then turns on with a blank citra screen with the bottom and top bar looking normal like I’m playing the game.

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (30.2 KB)

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                               Nightly 1784   HEAD-47c4f31
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 2400G with Radeon Vega Graphics     | AVX2 | FMA
Graphics API                                 OpenGL 4.3.1
Graphics Renderer                            Radeon(TM) RX 550
GPU Driver Version                           21.30.26 30.0.13026.3
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

I don’t really have time to disable the cheats because the game crashes legit like instantly.

Nevermind I turned the cheats off and the same thing is happening with no change what so ever

Did you restart the game after turning them off?

Update the drivers to 22.8.2:

THANK YOU!!! This worked perfectly

1 Like