My game crash when I try to open it again

Issue:
First time I open the game there is no problem you can play it all you want, but when you close it and try to open it again, citra closes again and again

System Information

  • Operating System: macOS Catalina 10.15.7
  • CPU: 3,4 GHz Intel Core i5
  • GPU: NVIDIA GeForce GTX 775M 2 GB
  • Citra Version (found in title bar): city nightly 1719
  • Game: Pokemon AS, Pokemon OR
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296
citra_log.txt.old.txt (6.1 KB)

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz | AVX2 | FMA
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz | AVX2 | FMA
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1719 HEAD-dfd7926
Operating System                              macOS 10.15
CPU                                           Intel(R) Core(TM) i5-4670 CPU @ 3.40GHz | AVX2 | FMA
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Seems like perhaps an issue with the Disk Shader Cache. Disable it in Citra>Preferences>Graphics>Advanced Tab.

If that doesn’t work, follow the steps below:
MacOS seems to have issues with some of the recent changes made in Citra. Perhaps your issue is related to that. Please try out this older Citra version to test this:
Download citra-osx-20200707-bd7ee8c.tar.gz from Release nightly-1587: Common: remove a mod from AlignUp (#5441) · citra-emu/citra-nightly · GitHub
Extract it and then run the citra-qt executable found inside of the extracted folder.

if I disable the Disk Shader Cache the game will run but with 1 ms, which is the same as not runing it, I will try the older version, which for now it lets me open the game, so I will try it and see if I can play without any inconvenience

I suspect your Citra might be running off of your integrated GPU, rather than you dedicated one. I couldn’t see this before since Citra crashed before the log could record it. It should now be recorded if you launch your game, so please upload a new log file with the Shader Cache disabled.