My Mom Hid My Game! crashes on boot

Issue:
Hi. I just bought My Mom Hid My Game off the eShop and tried running it on Citra, but the graphics weren’t being rendered properly making the game unplayable. I tried updating Citra, and now the game crashes entirely before the title screen loads.

After this I tried disabling hardware shader and updating my GPU drivers, but neither fixed the issue

System Information

  • Operating System: Windows 10 (x64)
  • CPU: Intel Core i7-6700K
  • GPU: NVIDIA GeForce GTX 970
  • Citra Version (found in title bar): Citra Nightly 1169
  • Game: My Mom Hid My Game!
  • Screenshot of Issue (include the full Citra window including titlebar): https://i.imgur.com/Kz5BtEB.png

citra_log.txt (2.6 MB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Maybe your save game got corrupted, right click on the game on citra’s game list and ‘Open Save Data Location’ either move your delete the ‘games.bin’ file.

Alright. I deleted the save data and now the game boots, but the graphics are messed up again. https://i.imgur.com/Jf4htF8.png

Also, the save data always gets corrupted so I have to delete it each time I want to run the game

citra_log.txt (267.4 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try changing ‘Region’ to ‘Auto-Select’ on Emulation > Configure > General > General. delete your save after that, launch the game and create a new save. close citra and copy your log file (somewhere else) that now contains what happened when you saved.

Open your game again and see if the save works, either way afterwards close citra and also copy the new log file, upload both of them.

Try enabling Accurate Multiplication & Accurate Geometry Shader in Configure - Graphics.
If it doesn’t work, try disabling Hardware Shader.
If it still doesn’t work try updating GPU drivers.

I’ve changed the region setting to auto-select, but that doesn’t seem to have changed anything unfortunately

Here are the two log files, save_create from when I started the game after deleting the save data (the game runs, but major graphical glitches make it unplayable), and save_load is from when I started the game without deleting the save data (the game drops to 0 fps and freezes before the title screen loads, and Citra stops responding when you attempt to exit the game or close Citra)

save_create.txt (266.2 KB)
save_load.txt (2.2 MB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Did you tried that:

if so, submit your issue here, include those last two log, your system specs, bug description and how to reproduce.

1 Like

Yep, I’ll go ahead and submit my issue on GitHub. Thanks for helping me troubleshoot :slight_smile: