My pokemon ultra sun dosent running good

Issue:
when im playing the game, the emulation speed drops to 80%-60% every few seconds, what setings do i have to change so it will be always on 100% speed?citra_log.txt (107.6 KB)

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1763 HEAD-777c13f
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 960M/PCIe/SSE2
GPU Driver Version                            446.14
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

umm… i dont understand…

Literally every few seconds or just when there is a new screen etc? You should enable Disk Shader Cache to reduce stutters, you might need to clear the old cache first just in case by opening Citra then File->Open Citra Folder and delete shaders\opengl folder.

i did what you suggest and it did helped! but there are still some drops but they are less big then before.
if you might know any other way i can improve the emulation speed i will be glad!

btw. the drops happening literally every few seconds

Since you are on a laptop you might need to do this:

Open Nvidia Control Panel and in Manage 3D settings, set Power management mode to Prefer maximum performance. If you have GeForce Experience installed, turn off Battery Boost:

Finally, use a high performance power plan in Windows, if you can’t select one you can create a new power plan on the left and select high performance that way.

wow! it helped even more! most of the time the game run normal (exept these moments that you enter a battle etc) thanks for the help!
if anything else comes up about some new ways to improve the emulation even in screen changes and battle intros, i will be glad to hear it here!
thx again!

1 Like