My PS4 controller not working anymore

My PS4 controller not working anymore:
I was playing Citra (usually Pokemon Y) with my PS4 controller connected by Bluetooth and it was working perfectly; until the last Citra Nightly update 1463. Now I’m unable to use it within the Citra, even though my PC registers controller as connected and working properly (tested in Steam, everything worked).

Is there any solution to this?

Thanks for the help!

System Information

  • Operating System: Windows 8.1
  • CPU: Intel Core i7-4510U CPU @ 2.00GHz
  • GPU: Nvidia GeForce GTX 850m
  • Citra Version (found in title bar): Citra Nightly 1463
  • Game: Pokemon Y

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

https://github.com/citra-emu/citra/pull/5123 from Canary recently got merged and requires you to rebind your controller to get it working again.

We have a report that it didn’t work with their Switch Pro controller but I have brought this up so hopefully they will look into it. Seeing as no one further reported Canary issues it seems it was fine to merge but apparently wasn’t :stuck_out_tongue:

Though I understand what is the problem, I have no clue how to fix it (or even if I can fix it) from the link you’ve sent. Is there any tutorial/step by step guide how to solve the problem?

The link is just for information what the change is about. You need to go into the controls settings in Citra and setup your controller again. If you get confused because there is no feedback other than [press key], you might need to reset the controls first.

I did try to re-setup my controller + reset the controls, yet I have still no response from Citra. I did also reconnect my controller to my PC (uninstalling and installing it again), but nothing seems to help.

Ok I will bring this up, for now you would need to rollback to an older version. You can find previous builds here: https://github.com/citra-emu/citra-nightly/releases

1 Like

Thank you for everything. The reverting to the older version did solve the issue and controller is working again. I hope the problem will be removed in the newer builds.
Have a nice day.

1 Like

May i know how to revert to older version?

May i know how to revert it back to the older version (Citra nightky 1462)?

Click the link above and click on an older Nightly version. Next, download the .7z file under Assets then extract it with like winrar or 7-zip.