My save files won't stay updated

Issue:
I’ve been having an issue with the save files for several days. English is not my first language, but I’ll try to explain the best I can:

It happens after I save my game and close the emulator. When I run the emulator again later, and open the folder with the file “main”, the “last modified” date doesn’t match the actual date, for example, today (May 24th) I was playing until 2:30pm, saved and closed the emulator. I checked in the carpet and the “main” file had the proper date and hour. A few hours later I open Citra again and the date of the save file is now 27/04/2020.
The first time it happened I stopped playing Pokemon X and started Omega Ruby for a few days and after an emulator update, everything went back to normal and I found my Pokemon X save file with the right date. I kept playing and it happened again a couple of days later.
I downloaded a version of Citra previous to the moment this problem started and it worked. I found my save file again and could play again: I’ve been using the same Citra version without problems but today I’m finding the same issue.
Whenever this happens, the date of the save file always regress to 24/04/2020.

I’m uploading a screenshot of the folder.

I don’t know if this could be somehow relevant but, today I had to unninstall an old version of Office and install a new one.

I hope someone can help me fix this problem please [citra_log.txt|attachment]

System Information

  • Operating System: Windows 10
  • CPU:
  • GPU:
  • Citra Version (found in title bar): 1546
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
(upload://52GqEf6NoSKeDH88ihbzLuuuQ7D.txt) (5.9 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Are you logged into a Microsoft account on your computer? Or a local account?

Hello.
It’s a Microsoft account.

It is possible there is an issue with that, I know another user where their cheats wouldn’t save at all.

Try download a standalone build (go to the download page and click Manual Download) and extract it somewhere on your computer that is not related to your current installation. e.g C:\new_Citra_folder. Then create a new folder called user where its citra-qt is and copy all files from %appdata%\Citra into it. Then you should be able to play on that version and keep your progress.

You will have to update manually though, there is no auto-update this way.

OK. I’ll try that.
Thank you very much.