My screen is black most of the time

Screen is black:
I’m trying to play pokemon alpha sapphire but when the game turns on only the top screen is on, then its off after I select the language, then its on again for about 1 second.

System Information

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, the log doesn’t have useful information. Try turn off Hardware Renderer then start the game and upload a new log after you close Citra.

It didn’t work it just made it run at 2 fpscitra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

The point was to get more info in the log, but it is still getting cut off :frowning:

I have a feeling you have outdated drivers but you will have to give more information yourself since the log isn’t doing it.

Go to Device Manager and show both Display adapters and processors, like this:

image

To show driver version, go to Properties for a display adapater and then click on the Driver tab, like this:

image
image

image Sorry that its in polish, but you can use your own to know what it means.

I do, but I need to know the name of it and your processor which you can see in my screenshots. Please show me.

image Like this?

Oh you have Nvidia, that’s good. To make Citra use it you need to open Nvidia Control Panel and then Manage 3D settings and set Preferred GPU to Nvidia. While you are there set Power management mode to Prefer maximum performance

If you have GeForce Experience installed turn off Battery Boost as well:

image i just read it again and i found the other thing you wanted

You might need to install the latest drivers too for the 920M: https://www.nvidia.pl/Download/driverResults.aspx/145946/pl

You can check what you have if you click the Home icon in Nvidia Control Panel.

I already have 920M and i turned on citra again and the problem is still happening

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Ok, you might need to do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I did that and its still black.

Ok, are you on 425.31 Nvidia drivers? If not, follow the link I gave earlier to install it. You might need to go custom install and check “clean install” so you have fresh drivers.

After the clean install of the drivers you need to set preferred GPU back to Nvidia as well as set Power management mode to maximum performance.

Oh i’m on 345.05 drivers but it still says GeForce 920M. I’ll go download the drives

My internet is pretty slow so it might take a while.

Its been resolved. Thank you very much for all the help.

1 Like