Need help with "enable hardware shader"

Issue:
Hello, recently when i play some game with the “enable hardware shader” option on, game speed is at 90-100% and it’s so good to play, however the game will freeze at some points (cutscreens, change maps, ect…), game still run, I can hear the music, foot steps ect,… but the screen is black. Turn off this option seem to fix this problem, but the game will drop to very low speed and it’s kinda annoying. Is there any way for me to still have the “enable hardware shader” option on without the freeze problem?

Help me please, i can’t help but cry for my potato laptop :((

System Information

  • Operating System: Window 10 Pro
  • CPU: intel® core™ i3-4030u cpu @ 1.90ghz
  • GPU: Intel® HD Graphics Family (20.19.15.5144)
  • Citra Version: Citra Canary 1414
  • Game: Yo-kai Watch 3, Monster Hunter Stories,…
  • Screenshot of Issue:

citra_log.txt (192.4 KB)

System Information for Support

Client Version                                Canary 1414 HEAD-57199fd
Operating System                              null
CPU                                           null
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.5144
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have cheats enabled. This might cause weird behaviour or crashes. Please disable them and retest if your game is experiencing bugs or crashes.

Enableing Accurate Multiplication doesn’t help.

Disable/delete cheats doesn’t help.

After disabling cheats, you need to restart citra, otherwise the cheats will stay in effect. You’re also using a very old version of citra. You may want to update to the latest version, unless you’re using that version to prevent some GPU issues.

Of course i restart after delete cheat :smiley: but that doesn’t help. And the newest version of citra have some issues when i play Yokai Watch 3 (scanning yokai very slow, but in version 1414 it’s fast). Maybe i will try another build.

That’s probably due to the disk shader cache bug.

Please try this version: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392

I have tried this version and canary 1763, the scan is fine, but problem with “enable hardware shader” still there. Thank you anyway :joy: