Need help with settings for optimal preformance on pokemon ultra moon

Issue:
Enter a description of your issue here, in full detail.
hi, im struggling to run pokenon ultra moon, and im not sure if its my settings or my dinosaur aged hardware. tried running it on my S10 as well, no real performance difference (ive tried most settings but i cant get it over 15) so id like some help with optimising my settings or a straight confirmation that my pc or s10 wont run this.

System Information

  • Operating System: windows 10 x64
  • CPU: intell core i5-4570S 2.9GHZ (base)
  • GPU: Intell HD 4600 (driver ver 20.19.15.4835)
  • Citra Version (found in title bar): nightly 1727
  • Game: Pokemon Ultra moon
  • Screenshot of Issue (include the full Citra window including titlebar): (no way to screenshot a low framerate, not sure but ill try with this scrsht to portay the framerate)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (178.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1727 HEAD-6183b5d
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4570S CPU @ 2.90GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            20.19.15.4835
CPU JIT                                       [ ]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • CPU JIT should be enabled for the best performance. Please enable this option.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

CPU JIT seems to have fixed it with minimal frame droppage, thanks for that. not sure why it didn’t work before since i have tried with that to no success before.

if possible could you also point me in the direction of getting this to work better on the android emu as well?
like just general optimisation settings and such.

Citra Android’s default settings are the best for performance generally speaking. You can try disable Accurate Shader Multiplication for a bit of extra performance in the Graphics settings. But other than that, performance is largely relient on your phone’s SoC’ OpenGL drivers.