New ARB Feature in EA Build Causing Blank Screen [Pokemon Sword]

yuzu_log_6-6-2020_blue screen.txt (2.0 MB)

Latest build of EA w/ ARB assembly. Audio still plays as normal, still responds to keyboard inputs, same FPS, just nothing rendering to the screen. My machine is dated (to say the least, lol), but I had high hopes for this latest feature…

Following errors repeat:

“[ 305.545382] Render.OpenGL video_core\renderer_opengl
\gl_shader_cache.cpp:BuildShader:169: line 7, column 39: error: program
option type not supported on this hardware”

and then at the end when the game itself is running:

[ 331.665519] Render.OpenGL video_core\renderer_opengl
\renderer_opengl.cpp:DebugHandler:182: API ERROR 1282: GL_INVALID_OPERATION
error generated. State(s) are invalid: vertex program, fragment program.

Can any dev make sense of this? Only tried with Pokemon Sword. Thanks!

System Information for Support

Client Version                                yuzu Early Access 594 HEAD-51882c7eb
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                 Intel(R) Core(TM) i7-3615QM CPU @ 2.30GHz
Graphics API                                  OpenGL 4.6.0
Graphics Renderer                             GeForce GT 650M/PCIe/SSE2
GPU Driver Version                            425.31
Docked Mode                                   [x]
Use Async GPU                                 [ ]
BCAT Backend                                  none
GPU Emulation Accuracy Level                  Normal

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Async GPU emulation is recommended as it can improve the performance of many games.

P.S. I had to cut down the log to make the upload go through (tried to just delete the repetition) - full log here: https://drive.google.com/file/d/178nZOZSMFkYxw9Ld7DzjttCWF9vYw5vX/view?usp=sharing.

To the bot’s comments:

  • 425.31 is the latest version Nvidia presents me with for my GPU… am I missing something?
  • Tried turning on Async, same issue. Same issue with multicore too (which actually lowers my already low FPS - any ideas on why?)

A fix is being worked on for Kepler cards, wait for a future early access version with it.

Great to hear! Thanks for the update.

Out of curiosity, do you know what it is specifically about Kepler that’s making these features break? (I say “these”, but the multicore issue is probably my CPU.)

Kepler lacks a needed extension for ARB, and yuzu was making it mandatory. The change will make it optional at the cost of possible graphical glitches.
The CPU is a current problem we have yeah, CPUs lacking AVX2 perform like that.