New GPU build doesn't render properly


#1

Issue:
Hello everyone, so my issue is kind of a weird one, i searched around for some similar cases, but to no avail.

Anyways, i got home excited to try the new build, launched it, and BAM, monstrousities, at first i though it was a problem for pokemon only, but then i tried a bunch other games, and found that some have same issues(DB fusion, Radiant Historia, One Piece…) while others don’t boot at all(Rune Factory 4, PQ, Bravely Default…).

And so my question is:does anyone have the same issues? or maybe it’s due to my system?
hopefully i get an answer. Thanks!

PS:when runing on CPU i get decent performance on most games, but i want to take adventage of my GPU.

System Information

  • Operating System: Windows 7 Pro 64
  • CPU: i7-3630QM 2.40GHz
  • GPU: Geforce GT 635m
  • Citra Version: Canary 9d89868
  • Game: Everything when set to GPU!
  • Screenshot of Issue :

#2

Try disabling or enabling the “Accurate Hardware Shader” setting in the Graphics tab.


#3

tried that, nothing changed


#4

Try set hw_shaders in qt-config.ini with a value of 2 i.e: hw_shaders = 2
and see what happens.


#5

Nope, unfortunately it’s still the same problem even after twiking in the config.ini.


#7

Why are so many people using the canary build. Use the nightly! Less issues.


#9

Canary only has this feature. Nightly doesn’t. I suggest opening a new support topic tested with Nightly.


#10

Ensure you’re using the same GPU as before. Citra doesn’t seem to re-compile the shaders when you switch from intergrated to dedicated or vice-versa which causes these kind of glitches. Just right click on Citra-qt.exe (or the shortcut to it) and select Run With Graphical Processor > Powerful NVidia-processor/Integrated graphics to force one of the two to be used.


Pokemon USUM's Screen freezes, but keeps going!
#11

i can’t believe that actually worked, you’re a life saver :smile:


#12

This might be a dumb question but where can I find Citra-qt.exe