New Super Mario Bros 2. randomly freezing on the intro cutscene

Issue:
When I open New Super Mario Bros 2. randomly during the intro cutscene (when koopalings kidnap Princess Peach) it freezes. In the bottom corner it says 0 fps but speed is 100%/100%. 2 seconds before the game freezes the audio mutes.

System Information

  • Operating System: Windows 10 Pro 64 bit
  • CPU: Intel Pentium G4560 3.50GHz
  • GPU: NVIDIA Geforce GTX 1050
  • Citra Version: Nightly 1816
  • Game: New Super Mario Bros 2.
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (19.9 KB)

System Information for Support

Client Version                               Nightly 1816   HEAD-d117132
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Pentium(R) CPU G4560 @ 3.50GHz
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce GTX 1050/PCIe/SSE2
GPU Driver Version                           526.98
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

Go to Emulation>Configuration>System and set the CPU Clock Speed slider back to 100%. You shouldn’t be messing with this unless you know what you’re doing.