New to 3DS emulation. How to optimize performance?

I recently build this PC with a friend and tried to give it some flexibility between higher tier games and some emulation. I’m at a consistent 30 FPS with some annoying hiccups here and there. A lot of the “optimization guides” on YouTube also tend to be on older builds, not on Nightly, or are non-reputable (dislikes far outweighing the likes). Someone please help me optimize Pokemon Ultra Moon, Fire Emblem Awakening, or just the emulator in general.

System Information
-Windows 10 (not activated)
-i7-9700K
-RTX 2070
-Citra Nightly 1611
-Pokemon Ultra Moon and Fire Emblem Awakening

Log: citra_log.txt (751.4 KB)

System Information for Support

Client Version                                Nightly 1611 HEAD-e48110b
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2070/PCIe/SSE2
GPU Driver Version                            452.06
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

your log looks good just enable accurate multiplication in emulation > configure > graphics > advanced

I did that but it still stutters quite a bit.

Go to file>open citra folder. Then open up the shaders folder and delete the opengl folder inside.
There’s a bug in the Disk Shader Cache when you’ve played without Accurate Muliplication on for a while, causing it to endlessly compile shaders. That leads to high ram usage and eventually crashing. So it’s good to clear the old cache if you’ve only just enabled Accurate Multiplication.

Still got like 5 stutters from the opening cutscene with Kukui in UItra Moon.

Is it just borderline impossible to run this emulator without some stutters? I woulda thought an i7-9700k and RTX 2070 could run this emulator flawlessly.

I’m running a GTX 1060 6gb + i5-6400 and I can run ultra moon at around 400% speed with no issues whatsoever. So yea, it’s probably not your specs that are at fault xD

Either I’m missing something in your settings or there’s some sort of conflict that I can’t see. We can try to set up a portable citra version to at least rule out issues with appdata or your settings.
Download citra-windows-mingw-20200930-aced133.7z (direct link) from https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1627
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Inside the extracted nightly-mingw folder, create a folder called user. Now run citra-qt.exe from the folder and run your game.
It should look like this:

Still a little bit of stuttering. Albeit they’re much shorter than my usual Citra.

citra_log.txt (59.6 KB)

System Information for Support

Client Version                                Nightly 1627 HEAD-aced133
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2070/PCIe/SSE2
GPU Driver Version                            456.55
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

You should enable Accurate Multiplication for the same reasons as before.

Enable it and delete the opengl folder again?

Also sorry for the really late reply, was busy.

If you’ve been playing without Accurate Multiplication for a while, then yes xD

citra_log.txt (36.0 KB)
Alright. Enabled the multiplier and deleted the folder. Left everything to the default minimum/auto settings and still getting some hiccups.

System Information for Support

Client Version                                Nightly 1627 HEAD-aced133
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2070/PCIe/SSE2
GPU Driver Version                            456.55
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Okay I thought I did… sigh… hang on again

Wait. Okay it was always on. I dont know why it says it’s not.
image

Restart citra, then upload a new log file

citra_log.txt (5.5 KB)
any suggestion to improve performance