New to Citra, Audio stutter/ Majoras Mask

#1

So, I followed this tutorial on how to install and get Citra working (The easiest way possible)

[Mod Edit: Video link removed]

I followed each and every step to the T, and was successful. (I also downloaded his setup file as recommended)

Everything works great, however the sound is still very choppy. I’m not sure if there is a workaround for this, and I feel I’ve searched from peak to peak of the internet trying to find a fix to no avail.

The only game I have at the moment is Majoras Mask, and I guess this and OoT are both notorious for having choppy audio, however when I watched this performance demonstration:

https://www.youtube.com/watch?v=X_ZSoBczNsI&t=67s

I hear no audio stutter whatsoever.

Can someone please help me with this, I’d really appreciate it.

System Information

  • Operating System: Windows 10 x64
  • CPU: i7 4770k
  • GPU: gtx 1060 6gb
  • Citra Version (found in title bar): Canary v.f69feeb /nightly Build v.45aa950
  • Game: Majoras Mask 3D

Diagnostic Log
(I don’t know what log file is required here)

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

Did you enable ‘Enable audio stretching’,? if not enable it.

#4

My log file says nothing

#5

and yes, It is always enabled.

If I don’t have it enabled, the sound becomes EXTREMELY distorted.

#6

Should I use an older build?

#7

yes, i think that’s the only solution for now.
do that, maybe later some moderator will link that issue to the issue tracker.

#8

also, if you find a build that works please share here which one.

#9

Try Nightly if the problem is gone than it’s the current SDL2.dll issue under Canary which should be fixed next week if an update happens.

#10

It also does it in nightly.

I’m going to install a previous build and get it working and see if the problem is still there.

If it isn’t it’s gotta be something with both current nightly and canary builds.

#11

If the audio stuttering occurs in Nightly, it probably isn’t a Citra issue and it’s on your end.

#12

Yea I’m not sure what it could be if it is.

I downloaded a previous version of Citra that came out on March 18th, and loaded the game up and the stuttering was still there, at first.

In this build (Nightly 595- 9e4670) when I turned off Audio Stretching the Audio is syncing perfectly.

When I turn it off in the most recent build, the Audio becomes EXTREMELY distorted and unrecognizable.

EDIT: Yea this game is running very well in the nightly 595 build.

1 Like
#14

same problem here …

#15

Try the nightly build 595 that was released on March 18th.

My game is running really well in this build and the audio is syncing perfectly at all times after turning off audio stretching.