New update causing rear camera to not show up

The area where the camera would usually appear on screen is just showing the background, and making any inputs unresponsive. This was not an issue in version 1760 or 1761.

  • Operating System: Windows 10
  • CPU: Intel Core 17-3770 - 3.40GHz
  • GPU: NVIDIA GeForce GTX 1660 Ti
  • Citra Version: 1762
  • Game: Yo-Kai Watch 3
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (76.2 KB)

System Information for Support

Client Version                               Nightly 1762   HEAD-1382035
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz | AVX
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            GeForce GTX 1660 Ti/PCIe/SSE2
GPU Driver Version                           456.71
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

I updated the driver and the issue is still present

Can you check the latest canary build as well?

How do I install the Canary builds

Through Citra’s maintenance tool, or by downloading them manually: Release canary-2122 · citra-emu/citra-canary · GitHub

Issue is still there

Please try out this build: Release canary-2103 · citra-emu/citra-canary · GitHub

That build isnt booting

Are you sure you downloaded the correct version? The one with “windows” in the name and ending with “.7z”?

I definitely downloaded that one

Define “that build isnt booting” a bit more. Is it refusing to launch Citra at all? Or is it crashing in-game?

When I try to launch it nothing launches, something shows up with no icon in the taskbar and then closes

Are you sure you’re launching citra-qt.exe, and not citra.exe?

Nope, i was trying to launch citra.exe i tried the qt one and it launched

Camera is still not working

That’s odd then. The change that happened from Nightly 1761 to Nightly 1762 isn’t present on that canary build. So it should function according what you said in your opening post. Let’s double check Nightly 1761 for sanity’s sake: Release nightly-1761 · citra-emu/citra-nightly · GitHub

I tried it, still didn’t work, I think it could be an issue with how my camera is plugged into my pc, because I moved it before updating citra, so its possible I confused that with the update messing it up

Although the preview is working fine when I look at it, so its appears to be an issue with the game

Make sure that you have the correct camera configured for the game’s function. Some games make use of both the rear and the front camera for different things. Since Citra can’t configure 2 camera’s, you’d need to switch which one is configured in your camera settings.