New update slow fps


#1

I was playing Pokemon Ultra sun yesterday and it was working really fine. But with the new update of today, I’m stuck at 15 fps and it’s not playable. What happened with this update?

System Information

  • Operating System: 10.0 build 16299
  • CPU: Intel I7 7700
  • GPU: GTX 1060
  • Citra Version (found in title bar): Citra HEAD-d76693c
  • Game: Pokemon Ultra Sun
    49% speed and 15 fps

When i try to upload my log, it says error.


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

Try disabling any limiters you might have put (like in Nvidia’s settings), disable both V-Sync and Accurate Multiplication in Citra - Emulation - Configure - Graphics.


#4

Not working, still the same =/


#5

Me too, the new update actually worsens performance


#6

I can confirm, something is very wrong. I’m getting about 50% lower performance regardless of settings.


#7

need to know what game you are playing, what hardware you are using, and so on.


#8

To help me narrow down where the issue is, someone please test the following two builds and compare the speed between them.

Build #1: https://ci.appveyor.com/api/buildjobs/ya36i1jpcbw66190/artifacts/citra-windows-mingw-20180515-d76693c.7z

Build #2: https://github.com/citra-emu/citra-canary/releases/download/canary-493/citra-windows-mingw-20180515-d76693c.7z

I don’t care what settings you use, just use the same settings for both tests.


Why is it so slow
#9

I tried both and there is no difference in performance to me.

OOT3D runs at around ~62 fps when walking outside the Shadow Temple, in the room with the lit torches.

PMD Gates to Infinity runs at around 54 fps when standing in front of Azumarill in Paradise.

PSMD runs at around 32 fps while running around Capim town.

Dont have access to Sun/Moon so couldnt test it with the game the OP was talking about.

Specs:
CPU: i5-3230m
GPU: GT 740m 2GB
RAM: 8GB DDR3
OS: Windows 7 Pro 64bit.


#10

In my case I have not had problems, I have not seen any apparent change that negatively affects the performance since version 450 in canary, only improvements in regard to emulation.
I’m sorry for my bad English.

My Specs:
CPU: Intel Pentium 4415u
GPU: Intel Hd 610
RAM: 8GB DDR4
OS: Windows 10 Pro 64bit.


#11

Game tested: Monster Hunter XX
Hardware: GTX 1050, I5-2400, 8GB DDR3, Windows 7
There’s no difference whatsoever for me between those two builds, both give me about 50% of the performance of the last build I remember working well - HEAD-1191910. I have not done much testing so I’m not sure if it’s exactly the last build with good performance or not, I can try to narrow it down if necessary. Both of linked builds give me ~45 FPS uncapped when standing in the same position in the first village, ~12ms frametime. Meanwhile HEAD-1191910 gives me 65-70 FPS with ~7ms frametime in the exact same situation. On a sidenote, in build #2 sound is basically completely broken unless audio stretching is enabled and if it is the quality is quite poor and is delayed by something like half a second, as far as I can tell this hasn’t been an issue in any other version that I’ve tried including build #1. Exactly the same settings used in all three cases.


#12

could you test canary 483 and 484? 484 is the first build to implement pull 3729 which fixes
shadows for all monster hunter games, while that doesn’t affect performance much it may at very high resolutions!?


#13

484 is indeed the build that ruins the performance while 483 is still unaffected. 60fps on 483 (which is actually already slightly lower than 482 which was the build I’m playing on mentioned in the previous post), barely 40fps on 484. It would be very strange if some sort of a shader fix lowered the framerate by this much though, because using the “unsupported” fix of switching hw_shaders to 2 in the .ini file incurred no performance penalty, in fact it made the framerate a bit better at least for my friend who’s using quite low-end hardware. Resolution also has nothing to do with this - normally I’m using 4x native, but out of curiosity I put it on 1x and the discrepancy while smaller is still there - 50fps 10ms on 484 vs 60fps 8ms - yes, completely no change - on 483. That said the aforementioned low-end hardware friend is running the game at 1x native at all times and he’s experiencing a drop from 25-30fps to about 10fps.


#14

Used a hopefully consistent “benchmark”, though I may not have been perfect with the start/end times for the profile. Canary 483 definitely had slightly higher fps (114 rather than 108 or so) but the difference seemed small.
Game: Hatsune Miku: Project Mirai DX
Settings: Uncapped framerate, sound stretching off, 10x resolution
CPU: i7-3770
GPU: GTX 970
RAM: 16GB DDR3
OS: Windows 7 Pro 64bit

Build #1:

Build #2:

Canary 483:


#15

How is that working?


#16

My pokemon sun performance took a nose dive a few days ago guessing due to the same update :frowning: