Newbie needs help with his own citra issues (Pokemon Alpha Sapphire)

Issue:
Opening a decrypted Alpha Sapphire .3ds file with citra crashes the program, sometimes a popup shows up, telling that my display driver stopped responding and has been recovered.

Deactivating “Hardware Shader” enables the game launch, but with graphical issues.

Disabling “Renderer Hardware” fixes the graphical issues, but at the cost of the game running at 3 FPS.

Emulation Speed and CPU speed have no effect on “fixing” the FPS problem with my settings.

System Information

  • Operating System: Windows 8.1
  • CPU: Intel Core i7-4700HQ CPU 2.40GHz
  • GPU: Intel HD Graphics 4600
    NVIDIA GeForce GTX 850M
  • Citra Version (found in title bar): Citra Nightly 1721
  • Game: Pokemon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (5.7 KB)

System Information for Support

Client Version                                Nightly 1721 HEAD-89410c1
Operating System                              Windows 8.1 (6.3)
CPU                                           Intel(R) Core(TM) i7-4700HQ CPU @ 2.40GHz | AVX2 | FMA
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

These issues appear similar to when Citra is run on a Hasswell iGPU (which is what your Intel HD Graphics 4600 is). So Citra might not be running on your NVIDIA GPU.

To force Citra to run on your dedicated GPU instead, right click on your desktop and select NVIDIA Control Panel. Head to Manage 3D settings and click on the Program Settings. Select citra-qt.exe from the list and set it to run on “High performance NVIDIA GPU” or something similar (it’s a bit different on different Windows versions).

Now try running Citra again and see if the issue remains. If it does, head to Emulation>Configuration>Graphics>Advanced Tab and turn off the Disk Shader Cache, then try to launch the game again. If it fails again, upload another log file.

This solved the issue in no time, i see some fps drops when loading new areas but this is perfectably acceptable as after said drops the emulation is doing smoothly.
Thanks for the help!

1 Like