No sound in latest Canary build (840)

#1

Issue:
I get no sound in the latest build.

System Information

  • Operating System: Windows 10
  • CPU:
  • GPU:
  • Citra Version (found in title bar): Canary 840
  • Game: Fantasy Life

I rolled back to 838 and it works fine. I didn’t try 839, as 838 was the last working known version for me. I’m using a Logitech USB headset.

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

You can find these build here, do try those two build to find on which this issue began to happen.

#4

Okay, 839 works. 840 is where the no sound issue starts.

#5

Same issue here. Works fine in 839, 840 has no audio.

A workaround I found is to go to Emulation > Configure > Audio and simply click “OK”. Even if no changes are made to the settings, doing this will restore audio until the emulator is closed and re-opened.

1 Like
#6

A known issue that is currently being worked on.
Please see https://github.com/citra-emu/citra/pull/4194

1 Like
#7

The issue is fixed on my side. Please update to Canary-841.

#8

That was really fast. I can confirm the issue’s fixed in Canary #841!

#9

same no sound, but after i set the view to default and change it to another size and back to default again the sound was fixed