No textures loading in Pokémon Ultra Sun/Moon

Issue:
Everytime I try to load Pokémon Ultra Sun or Ultra Moon, textures doesn’t load. I tried it on Nightly and Canary versions of Citra. Worth noticing that I’ve been playing Pokémon X just fine, and that my game is in portuguese. For illustration proposes, here’s some screenshots:

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i3-4005U CPU
  • GPU: @ 1.70 GHz 1.70 GHz
  • Citra Version (found in title bar): 1928 on both Canary and Nightly
  • Game: Pokémon Ultra Sun and Pokémon Ultra Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (18.0 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1928 HEAD-625639a
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-4005U CPU @ 1.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.4642
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Please enable the Vsync option if you are experiencing screen tearing.

These drivers are out of date you’ll need to update: Download win64_15.40.47.5166.zip (direct link) from https://downloadcenter.intel.com/download/29971/Intel-Graphics-Driver-for-Windows-15-40-

then follow this guide to install them: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Furthermore, because you iGPU has driver bugs, you’ll need to disable Accurate Multiplication in Emulation>Configuration>Graphics>Advanced Tab to prevent some graphical issues from occuring.

1 Like

It worked! I’m really sorry about the nuisance and thank you so much for taking your time to help me with this.

Anways, stream Phoebe Bridgers’ grammy nominated album, Punisher. Thanks again!

1 Like

Plz help i have the same problem
And i already have updated the drivers