Not able to configure bluetooth controller

Not able to configure bluetooth controller on an Android phone.

System Information

  • Operating System: android 11
  • CPU: snapdragon 865
  • GPU:
  • Citra Version (found in title bar): 89204de7b
  • Game: pokemon alpha sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):
    I am getting this message:

This control must be bound to a gamepad analog stick or D-pad axis!

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:


In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log[1].txt (113.9 KB)

Here you have

Worth mentioning that I have tested the control with another emulator and it’s working just fine and also tested it with the Citra version of Windows and it is also working. Just in my Xiaomi phone the Emulator is not recognizing the D-Pad, Circle Pad and C-stick

I have experiment the same problem, I have been using a xbox one controller to play citra but now the app don’t recognize de D-Pad, circle pad and the Z triggers

Noticing this is the snapdragon 865, like my S20, I wondered if this could be an Android 11 issue instead of a Citra issue, and sure enough:

Shutting off my button remapper in accesibilities services solved the issue for me. Analog sticks, D-pad, and triggers were recognized afterwards.

I have to turn off one configuration in accessibility
Hope that also works for you, I’m not able to post more than 3 images and not more than 3 times, in last screen you have to enter to configuration and turn off “automatic selection”

1 Like

Have forgotten to mention but in this section you have to turn on and then off the improved accessibility!


Hey thanks for the response, I did what you suggested and I’m still unable to configure the sticks or D pad. Below an screenshot, not sure if that was the settings that I needed to turn off

Forgot to mention that I’ve tested the control with Citra in a Windows PC and it is running just fine, also tested it with another emulator and it worked

You are a life saver, this gave me such a headache. Thank you so much

1 Like

How you do it?? I already try all of the above solution but still cant direct the conroler :cry:

Hey, actually following what Erick shared above ended up working for me, hope it works.

How you do it? I already turn off all switch acces on accesbility menu and switch acces settings like auto-select etc. ?

After comparing your settings vs mine, the only thing I see different is in the section called “Menu Customization”, there turn on the option “Enable Menu Customization”

Then on the section “Customize scanning” enable the one called “Auto-select”

Hope it helps.

how to solve this problem… I try solution above… but no works on me

Up please, I tryied everything described above but it still doesn’t detect joysticks and d-pad…
Everything works well with other apps, the problem only occurs on citra

After make all things that are here, still doesn’t work the joysticks, so try to turn off the one handed mode, I dont know why, but after turn off the one handed mode, the joysticks start to work, hope works for you.

1 Like

we are in the same, I still cannot solve the error, I followed the steps of our colleagues and nothing it works in my Poco X3 Pro and it only happens to me in citra :frowning:

1 Like

for POCO, go to additional settings>accessibility>physical>Autoclick(Dwell timing) > turn it off