OBS makes Citra crash

Issue:
When I try to stream with OBS, Citra immediately crashes. It doesn’t matter what game I choose or whether I select “preview stream,” “start recording,” or “start streaming” in OBS, whenever I click one of those, Citra crashes. This happens whenever source is set to Game Capture. Window Capture works okay but because I have it windowed to view twitch chat, the game screens are off to one side with a large black void on the side. I also don’t like having the “File / Emulation / View / Multiplayer” ect tab visible. Doing game capture would fix both of those problems, but as I said in the beginning, that crashes Citra.

System Information

  • Operating System: Windows 10
  • CPU: 4-core Intel i7
  • GPU: NVIDIA GeForce GTX 960M
  • Citra Version (found in title bar): Citra Nightly 1599
  • Game: Etrian Odyssey V / Fire Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (12.3 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1599 HEAD-b94f21e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 530
GPU Driver Version                            22.20.16.4749

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Go into Nvidia Control Panel and in Manage 3D settings, set Preferred GPU to Nvidia.

While you are there, set Power management mode to Prefer maximum performance. If you have GeForce Experience installed, turn off Battery Boost:

If you want to use Intel quicksync you should probably update the iGPU drivers:

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8476.exe from: https://downloadcenter.intel.com/download/29784/Intel-Graphics-Windows-10-DCH-Drivers?product=88967
direct link: https://downloadmirror.intel.com/29784/a08/igfx_win10_100.8476.exe

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Enable Disk Shader Cache (will help against some stutters)
  5. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

1 Like

Wow I had no idea that GPU was set to auto! I thought I’d fixed that ages ago. Thanks so much, that was undoubtedly most of the problem. Citra seems to work just fine with OBS now, I can’t thank you enough! I’m kind of a dummy when it comes to computers so thanks so much for helping!

As for the Citra configuration, Disk Shader Cache was greyed out unfortunately, so I couldn’t enable it. I did enable Accurate Multiplication though.

1 Like

If it is greyed out then that usually means Hardware Shader is turned off but Accurate Multiplication depends on Hardware Shader too. Hm.

Well at least you fixed the underlying issue with OBS :slight_smile: