Ocarina of Time 3D and motion controls for aiming

Issue:
I have a strange issue with OOT, perfectly emulated by the new version of Citra and the beautiful controls offered by DS4Windows. Sadly, the gyroscope emulation (both the one emulated via the right mouse button or the one built in my Dualshock4) only works for “looking around” in the game world (holding L button), but it doesn’t work for nothing else :frowning: - for example, aiming when using the slingshot. I made a video to better understand it: https://youtu.be/wmr1WbDmzHc
Is this just my issue? Thanks for helping!

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel Core i5-3570k
  • GPU: Nvidia GTX1050 Ti
  • Citra Version (found in title bar): Nightly 1372
  • Game: The Legend of Zelda - Ocarina of Time 3D
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (18.9 KB)

System Information for Support

Client Version                                Nightly 1372 HEAD-35690e3
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            388.13
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

System Information for Support

Client Version                                Nightly 1372 HEAD-35690e3
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050 Ti/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            388.13
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

Btw, installed latest nvidia drivers (good bot), issue still present of course.

Interesting. I’ve never tried the gyro controls in OoT, as I’m not a fan of that control scheme.

Do you experience the same issue in the latest Canary build? I’ll try to replicate the issue in about 12 hours once I’m home from work.

Tried now Canary 1492, same issue.

So, have you replicated the issue? I’m just curious to know if it’s only me :slight_smile:

I apologize, I forgot to replicate the issue after work. I’ll set a reminder, and see if I can take a look tonight.

Hello,

I just tested motion controls in OoT and verified that they work perfectly fine for the slingshot. I’m using Canary 1492.

Can you download the latest Nightly / Canary to see if that resolves your problem?

Already tried the last canary, strange :frowning:
Oh well, I’ll try something else, maybe it’s some DS4Windows configuration or whatever. Thanks anyway!