Ocarina of Time 3D runs at 17% of full speed despite my hardware and what I've tried with options

Recently updated citra to the latest nightly and dumped all of my titles and everything else with threeSD. Tried to play Ocarina of Time 3D and ran into the game running at an absolute snail’s pace. Tried playing with the internal resolution from native, up, down and auto. Disabled hardware shading, tried both with accurate multiplication on and off. Played with the clock speed because past posts on here have indicated that lower CPU clock speeds can weirdly fix the problem. Not sure why I’m getting such poor performance with the game

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 2600 X Six-core
  • GPU: NVIDIA RTX 2060 Super
  • Citra Version: Nightly 1904
  • Game: Ocarina of Time 3D

Diagnostic Log
citra_log.txt (27.3 KB)

Update and solution:

Found this literally minutes after posting this. I had my audio configuration set to the quality-oriented option and setting the audio to the fast one (which barely affected its actual presentation in gameplay) completely corrected the performance and now Ocarina plays flawlessly at 4x native internal resolution.