Ocarina of Time: Black jailbars

#1

Issue:
When I full screen the game there is always black bars at either side when I am playing single screen. I’ve tried 1920x1080, 1440x900, 1280x720 and the automatic option but nothing removes them. I also tried changing the values in the settings.ini file but it only seemed to work with the side-by-side option.

Sorry but I can’t provide a screenshot as when I try to take a screenshot in full screen mode it just takes a screenshot of my desktop.

tldr: How do I remove the black bars from either side when playing single screen, full screen Zelda Ocarina of Time?

Any help is appreciated, thanks in advance.

System Information

  • Operating System: Windows 7
  • CPU: I5 4690K
  • GPU: 270X
  • Citra Version (found in title bar): HEAD-50def5a
  • Game: TLOZ:OOT
#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

You will have to offer custom layouts.

#4

Thanks for replying. I have tried that, e.x.:

[Layout]
layout_option=1
swap_screen=false
custom_layout=true
custom_top_left=0
custom_top_top=0
custom_top_right=1280
custom_top_bottom=720
custom_bottom_left=0
custom_bottom_top=0
custom_bottom_right=0
custom_bottom_bottom=0

However, the lower screen won’t disappear, it stays in the middle of the screen.

EDIT: Ok, so I managed to get rid of the lower screen with the above text. But no matter what resolution I choose with these lines, the black bars still remain.

custom_top_right=1280
custom_top_bottom=720

#5

Lol, that won’t work! Depends on what style of layout you want. I can design one for you.

#6

Thanks for the offer. I really just wanted full screen single screen with out black bars. Unless you can make a layout which makes that possible?

I don’t know why the Citra developers didn’t make something to remove these black bars, or perhaps its the game, I don’t know but its annoying!

#7

That would need the screens to be stretched, so it’s considered inaccurate emulation (probably, idk for sure). I’ll send the layout here when it’s ready. I can’t test it tho.

#8

Wait, this is the correct config for single screen! Can you post a screenshot?

#9

Hi please see attached.

Citra won’t let me take a “real” full screen screenshot, so I just resized the windows so you can see what I’m attempting to do.

#10

The 3DS top screen is not 16:9 (it’s more like 5:3) so there will be black bars on the side since Citra keeps aspect ratio. If you want to completely fill the top screen you will need to use a custom screen layout. Keep in mind this will stretch the image.

1 Like
#11

I see. Stretching the image sounds like a bad idea then if this is the native aspect ratio. I will leave it with the 5:3 black bars. Thank you all!

Although, there is no “zoom” function? To cut off some of the vertical size for some horizontal? I could give that a try and see how it looks.

2 Likes
#12

There is no feature like that.

1 Like
#13

Hi Leo, I’m trying it on another monitor (non-PC monitor) and it looks like this: (recreated in Paint)
oot

The monitor is showing 720P60 and my PC resolution is set to 1280x720. I have tried Citras “1200x720” and “auto size” options but it stayed like this. Could you help me out by providing me with one of these custom screen layouts for 1280x720? Hopefully that will work. If not, I can just adjust the custom one more and hopefully get it to fit correctly.

Thanks in advance.

#14

You don’t have to recreate it in Paint. You can simply take a screenshot of it. Also need to know exactly what monitor you’re using. I’m not certain that 1280 x 720 is the monitor’s resolution.

#15

Earlier I was pressing the print screen button in full screen then pasting it to paint and it would only print screen my desktop.

My set up is rather complicated but I’m using a Sony BVM D24E1WE CRT (http://www.broadcaststore.com/pdf/model/670625/bvm_dseries.pdf). I am using an Extron 203 RXI to convert the RGBHV (VGA) signal to RGBs via BNC (as RGBHV isn’t compatible with this monitor).

When its all hooked up, I have no problems with the Windows PC desktop and other programs displaying in 1280x720 (it fits the screen just fine). So I don’t think the set up is causing any issues.

It’s only when I full screen Citra that it doesn’t fit the screen. Perhaps this is just due to the 5:3 aspect ratio/3ds slightly resolution? I assume so, but I don’t think it should look this squashed as shown in the image in my previous post.

#16

Probably has to do with the converter. Also I’m not very good with custom layouts.

#17

I will get a picture of what it looks like next time I boot it up. Perhaps, but all it is doing is converting the signal type, plus it works with other emus etc, so personally I don’t think so. There’s a few more things I can try so I’ll do that. Thanks for the help, Leo.

If anyone could make me a custom layout so I can try that – I’d really appreciate it. I have no idea how to do it correctly.
f7b1914abbb5aa8d5270bcc35cc3771d

#18

So I managed to fix the problem, it turns out that it wasn’t Citra outputting a different res/aspect ratio to what my PC was outputting. I had to go to AMD control center and switch preserve aspect ratio to full and now it displays the correct resolution at 1280x720 with no black bars (apart from the original black bars on the side), which as Leo said are because of the 3DS’s different “5:3” aspect ratio.

Hopefully this post helps someone else that may come across this issue in the future!

1 Like