Ocarina Of Time Texture Problem-Glitch

After 5 minutes from game starts, (I am changing rooms), and the textures on my distant sight changing into the another rooms textures. When I walk towards it, it disappears. If I spend more time in game issue gets bigger.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (36.9 KB)

System Information for Support

Client Version                                Nightly 1547 HEAD-213c956
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon (TM) R7 370 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

Client Version                                Nightly 1547 HEAD-213c956
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon (TM) R7 370 Series
GPU Driver Version                            20.2.2 26.20.15019.19000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

This most likely a bug with texture filtering and mipmaps. For now turn off like xBRZ.

I have tried turning off the xBRZ, actually I tried every single Texture Filtering in the emulator.

It still happens with no texture filtering? You might need to restart the game if you had the glitch with xBRZ then disabled it without restarting.

I tried that one too. This time textures are corrupting.