Ocarina of Time textures issue

I have been playing Ocarina of Time 3D for some time now. It runs really great. The only issue I have is in some temples distant textures are not being correctly displayed. When I get closer, they change into the correct texture. It seems like the wrong texture is being displayed and then corrected when closer. I looked, but I could not find a post about this. Any help? Thanks a lot.

System Information

  • Operating System: Windows 10
  • CPU: Athlon FX 4100
  • GPU: Nvidia MSI GeForce 1060
  • Citra Version (found in title bar): Citra Nightly 1536 (2020-05-04)
  • Game: Ocarina of Time 3DS
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
<citra_log.txt (103.1 KB)

>

System Information for Support

Client Version                                Nightly 1536 HEAD-36809b2
Operating System                              Windows 10 (10.0)
CPU                                           AMD FX(tm)-4100 Quad-Core Processor            
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1060 3GB/PCIe/SSE2
GPU Driver Version                            445.75
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.