Omega Ruby gets stuck in every route past Slateport

Omega Ruby gets stuck in every route past Slateport:
Was playing Omega Ruby. Got up to Slateport, but afterwards, if I tried to continue onwards, the top screen would go black and the FPS would drop to 0. Tried looking up how to fix the problem by seeing if anyone else had a similar one which was solved, but no matter what I do, it doesn’t work.

System Information

  • Operating System: Windows 11 Home
  • CPU: 11th Gen Intel(R) Core™ i5-1135G7
  • GPU: Intel(R) Iris(R) Xe Graphics
  • Citra Version (found in title bar): Citra Nightly 1779
  • Game: Pokemon Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (378.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1779   HEAD-58d0705
Operating System                             Windows 10 (10.0)
CPU                                          11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz | AVX512 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            Intel(R) Iris(R) Xe Graphics
GPU Driver Version                           31.0.101.3222
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Are you playing any sort of ROM hack or randomization?

It’s a rom hack that’s only got a few changes to what Pokemon can be found, as well as some changed teams, and increased shiny odds. I’d tried hacks like it before, and those worked fine, so that’s what leaves me confused about this one

If it only changed small things like that, back up your save data, then load your base ROM in Citra. Select your save file and see if the same behavior occurs when entering that area. That would be a relatively easy way to test out whether the ROM hack is causing any issues here.

Ok I tried it using the save file on the base rom, and it actually did allow me to continue. I guess for some reason it’s a problem with the rom. Don’t know what the problem there is, but I’m glad I now know it’s not a problem with Citra. Thanks

1 Like