Omega Ruby loads but runs very slowly and freezes

Issue: Omega Ruby runs but it’s extremely slow and laggy.
Enter a description of your issue here, in full detail
I will load up the game and the music will start after a few seconds, but then the screen freezes and music stops then starts again but is really slow making the game unplayable.

System Information

  • Operating System: Windows 11
  • CPU: Intel(R) Celeron(R) N4020
  • GPU:
  • Citra Version (found in title bar): Citra Canary 2330
  • Game: Pokémon Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):

    citra_log.txt (26.6 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Canary 2330   HEAD-bf469e3
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Celeron(R) N4020 CPU @ 1.10GHz
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) UHD Graphics 600
GPU Driver Version                           27.20.100.8681
CPU JIT                                      [x]
Hardware Renderer                            [ ]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

This driver is out of date. To update, download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Let me know if you encounter any issues during the installation.

Additionally, re-enable Hardware Renderer in Emulation>Configuration>Graphics>Advanced Tab.

My Citra has been updated to Canary 2331 and i download the GPU thing but my game is still really slow.
citra_log.txt (26.8 KB)

System Information for Support

Client Version                               Canary 2331   HEAD-5b9d126
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Celeron(R) N4020 CPU @ 1.10GHz
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) UHD Graphics 600
GPU Driver Version                           27.20.100.8681
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

I didn’t reply to this by accident, sorry

Right click on your game in Citra’s game list and select Properties. Enable the Hardware Renderer setting here as well. The log file indicates that you had this turned off on both sides.

Additionally, it appears Windows made the driver revert back to the old version. Are you absolutely certain it installed correctly before? If it did, we have 2 ways to make sure the updated drivers sticks around next time.

How do I make sure the updated driver stay? Thank you

Update to the latest driver again, then follow the instructions given here:


I know this peaks of Radeon, but it should work the same for Intel.

If that doesn’t work, you can also use this tool (again, update to the latest driver before running this tool:
https://web.archive.org/web/20190208013517/https:/download.microsoft.com/download/f/2/2/f22d5fdb-59cd-4275-8c95-1be17bf70b21/wushowhide.diagcab
You can use it to select your Intel driver and have Windows not “update” to the older driver again.

citra_log.txt (87.5 KB)


It’s now running fast but a black screen…

System Information for Support

Client Version                               Canary 2334   HEAD-a1159c0
Operating System                             Windows 10 Version 2009
CPU                                          Intel(R) Celeron(R) N4020 CPU @ 1.10GHz
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            Intel(R) UHD Graphics 600
GPU Driver Version                           27.20.100.8681
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Support for Intel® Graphics

Sorry, which method did you use? You still appear to be on an outdated driver?

I tried using the first one, but it didn’t let me click Roll Back Driver.

I then tried the second one and the options were hide hidden updates or show hidden updates

Neither of these options work when the latest driver isn’t installed yet.
You need to update to the latest driver first, then you can roll back your driver (or use the tool). It won’t work at all otherwise.

So, download and install gfx_win_101.3790_101.2114.exe from Intel® Graphics – Windows* DCH Drivers
Mirror download: https://downloadmirror.intel.com/751359/gfx_win_101.3790_101.2114.exe

Then try either option again.
For the second option (you showed in your screenshot), click on the Show hidden updates. That’ll allow you to select the Intel driver.

Ok so I just went on the game now and it is working perfectly. Thank you.

1 Like