[OOT 3D] Trouble with cheats : txt file not detected, and manually entered ones don't save

Issue:
Hi everyone !
I’m new to emulation, citra, and this forum.
I’ve gotten TLoZ OOT 3D (ID : [0004000000033600]) to work, and I’ve downloaded some cheats from here : CTRPF-AR-CHEAT-CODES/Cheats/The Legend of Zelda - Ocarina of Time 3D (EUR) at master · JourneyOver/CTRPF-AR-CHEAT-CODES · GitHub.

BUT it doesn’t appear in the cheats menu

  • the most common answer (that is "import your txt file to C:/Users/“PCname”/%APPDATA%/Roaming/Citra/Cheats ") does not work, my exe file being C:\Users\Daphne\AppData\Local\Citra\nightly-mingw. I do not have roaming but local, then I have a nightly-mingw subfolder instead of citra alone. I think it is related to the fact that I have the nightly version, and its last update ?
  • thus, I tried adding the cheats manually, and they work in-game (so it’s not the problem) BUT they do not save : dunno if that’s when opening/closing citra but they erase themselves.
  • so I tried again the txt file import method again.
    → My file name is the game’s ID without the “.txt”, in txt format and correctly written.
    → I do not have a “user” or a “cheats” folder, so I created them. So far I tried putting the cheats file in a newly created cheats folder in C:\Users\Daphne\AppData\Local\Citra\cheats (newly created)\my txt file, then in C:\Users\Daphne\AppData\Local\Citra\nightly-mingw\cheats (newly created)\my txt file, then in each subfolders of this path (the subfolders being imageformats, mediaservice, platforms, and scripting (without much hope, but ya know, global testing)).
    Opened the game at each step, the cheats menu stayed blank.

Then I tried putting “user (newly created)\cheats (newly created)\my txt file” in C:\Users\Daphne\AppData\Local\Citra but it did not work either, it even made my game files repositories disappear form citra (reversed now, is okay)

So I’m kinda blocked, does someone have an idea ? I’ve been stuck for a few days.

System Information

  • Operating System: Win 10
  • CPU: Intel(R) Core™ i5-7200U CPU @ 2.50GHz 2.71 GHz
  • GPU: Intel(R) HD Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1697
  • Game: The Legend Of Zelda : Ocarina of time 3D
  • Screenshot of Issue (include the full Citra window including titlebar):
    Two of the most commons paths not working :

Diagnostic Log
citra_log.txt (12.0 KB)

System Information for Support

Client Version                                Nightly 1697 HEAD-b3cab3c
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            22.20.16.4735
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Try extract a manual build and create a new folder called user in its “mingw” folder.

https://citra-emu.org/download/ then click “manual download” then click on the Windows icon. You can extract it with like 7-Zip: https://www.7-zip.org/

It should look like this:

If you want to copy over settings from the main build, copy everything from %appdata%\Citra (short for C:\Users\%username%\AppData\Roaming\Citra) into that user folder.

You should also update the drivers:

GPU Driver Version: 22.20.16.4735

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from: https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed 6373, download and install igfx_win10_100.9316.exe from: https://downloadcenter.intel.com/download/30266/Intel-Graphics-Windows-10-DCH-Drivers
direct link: https://downloadmirror.intel.com/30266/a08/igfx_win10_100.9316.exe

Make sure Windows 10 is updated, you should be on the 20H2 update.