OpenGL 3.3 but mine is 4.1

citra_log.txt (21.3 KB)
Issue:
Enter a description of your issue here, in full detail.
Hi my GPU support 4.1 OpenGL but it says it is not primary. Tryies to open with Intel HD Graph. I think there is one more topic about this but its unsolved so can you help me ?

System Information

  • Operating System:
  • CPU: Intel® Core™ i7-2670QM
  • GPU: Radeon ™ HD 7690M XT
  • Citra Version (found in title bar): Nightly 1272
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1272 HEAD-186ffc2
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics Family
OpenGL Version                                3.1.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Your GPU hardware only supports OpenGL version 3.1.0. Citra requires OpenGL 3.3.0 and above. https://citra-emu.org/wiki/faq/
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

At least answer pls im looking on the net if i find then i will give the solution here sorry to bother you guys

Yeah thank you i deleted all my grapihc card drivers then re-installed again and the problem solved. First i tried to open AMD Catalyst Control Center and it gave me some kind of error so re-installed everything and problem solved.