OpenGL 3.3 Error and i can't play Pokemon Moon :(

Issue:
I Get the Opengl 3.3 error i only have Intel Integraded Graphics and i uptaded my drivers i can’t install OpenGl Because i don’t have a NVIDIA Graphics Card.

System

  • Operating System:Windows 10 x64 Bit
  • CPU:Intel Celeron CPU B800 1.5 GHz
  • GPU: Intel HD Graphics
  • Citra Version (found in title bar):Citra HEAD-3eaafb2
  • Game:Pokemon Moon (Patched To Fix The Black Lines)

*BTW: i’m also using versions like the newest Bleading Edge and Citra Speed V2 (Intro Fix)

*Log:Citra Speed V2 (Intro Fix)/user/config/qt-config.ini
[ 0.131210] Frontend citra_qt\game_list.cpp:PopulateAsync:78: Could not find game list folder at C:/Users/Hamsi/Desktop/CITRA POKE SPEED IMG Ver.0.2/citra off 31-8/Roms
[ 0.131552] Frontend citra_qt\main.cpp:BootGame:338: Citra starting…
[ 0.155389] Service.FS core\file_sys\archive_sdmc.cpp:ArchiveFactory_SDMC:20: Directory C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sdmc/ set as SDMC.
[ 0.160813] Common.Filesystem common\file_util.cpp:CreateFullPath:194: path exists C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sdmc/
[ 0.161065] Service.FS core\file_sys\archive_savedata.cpp:ArchiveFactory_SaveData:42: Directory C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/ set as SaveData.
[ 0.161268] Service.FS core\file_sys\archive_extsavedata.cpp:ArchiveFactory_ExtSaveData:62: Directory C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/extdata/ set as base for ExtSaveData.
[ 0.161591] Common.Filesystem common\file_util.cpp:CreateFullPath:194: path exists C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/extdata/
[ 0.161807] Service.FS core\file_sys\archive_extsavedata.cpp:ArchiveFactory_ExtSaveData:62: Directory C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/nand/data/00000000000000000000000000000000/extdata/ set as base for ExtSaveData.
[ 0.162097] Common.Filesystem common\file_util.cpp:CreateFullPath:194: path exists C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/nand/data/00000000000000000000000000000000/extdata/
[ 0.162494] Common.Filesystem common\file_util.cpp:CreateFullPath:194: path exists C:\Users\Jafar\Desktop\Citra Speed V2 (Intro Fix)/user/sysdata/shared_font.bin
[ 0.214428] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:Init:496: GL_VERSION: 1.1.0
[ 0.215098] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:Init:497: GL_VENDOR: Microsoft Corporation
[ 0.215270] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:Init:498: GL_RENDERER: GDI Generic
[ 0.215430] Render video_core\video_core.cpp:Init:35: initialization failed !

*Please Help Me!

Use the official build they are much faster and stable and if you have msi afterburner opened try closing it.

okay i think your gpu doesnt support open gl 3.3

your gpu does not support opneGL needed to run citra.

we do not support unofficial builds here and discussing them is prohibited.

there is nothing that can be done to help you, you’re out of luck.

I also tried usning the newest bleeding edge build it says “Citra has encountered an error runing the video core please log it on the fourms and i did” i can try the Nightly Build?

Yes i know it does not support OpenGL It’s an Intel GPU but can i make Citra run without it?

“Intel® HD Graphics” only supports up to OpenGL 2.1 3.1

You can try run the game without hardware renderer, but it will probably be a slide show :slight_smile:


Ok Thanks for the help but that’s really stupid that Intel can’t have OpenGL 2.2 and up :frowning:

Intel does have the latest OpenGL versions on more recent HD Graphics.

It’s just that your laptop was way underpowered even when it came out and didn’t have a dedicated GPU.

Even if your laptop would have OpenGL 3.3, it wouldn’t even handle the most easiest to run games on Citra due to very low single core performance.

(also fixing @tywald: this version of HD Graphics can provide OpenGL up to 3.1.)

Also noticed something. You didn’t even install the drivers for your integrated GPU. You can get them here.

Oh, did I look at the wrong table? Since I looked at this one:

since it strictly said “Intel® HD Graphics” as mentioned at the B800 page. The later generations have a number next to it, for example my i7 3770K has HD 4000.

lol was just about to say… had the screenshot on the clipboard :smiley:

I installed them after i posted the log and same error

hi there i have the same problem with citra i am not able to play pokemon omega ruby it shows opengl 3.3 not supported & i am using official citra nightly #966 plzz help me out

hi there i have the same problem with citra i am not able to play pokemon omega ruby it shows opengl 3.3 not supported & i am using official citra nightly #966 i even updated it to citra nightly #992 & its still not working plzz help me out

This is a very old thread. Please create a new one with all the details filled in. And please provide a log.