OpenGL 3.3 Error despite GPU supporting OGL 4.2

Issue:
Enter a description of your issue here, in full detail.

I’m getting the OpenGL 3.3 error despite having a GPU that supports up to OGL 4.2.
It is a secondary GPU, i did update the drivers to latest, and included the citra exe in the list of apps that should use this GPU instead of my iGPU in the Catalyst Control Center.

System Information

  • Operating System: Win 7 Home 64bit
  • CPU: Intel Core i5 2410M
  • GPU: ATI AMD Radeon HD 6700M Series
  • Citra Version (found in title bar): Citra Canary 1627
  • Game: Etrian Odyssey IV US
  • Screenshot of Issue (include the full Citra window including titlebar):

    Diagnostic Log
    Upload your log file as an attachment by dragging & dropping.
    citra_log.txt (4.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

Thanks in advance,

P

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

citra_log.txt (8.1 KB)

updated logfile after trying new drivers.

Citra now freezes without displaying any error (i guess that’s progress?) and i have to kill the process via the task manager.

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [ ]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Turn off Enable Hardware Renderer then redo the steps for the log, hopefully it won’t get cut off this time.

citra_log.txt (8.1 KB)

No luck sadly but thanks for the quick reply!

System Information for Support

Client Version                                Canary 1627 HEAD-4a03207
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I don’t really get it…
Two posts above you asked me to turn off Hardware renderer while the log had it unticked,
Now I turn it off and the log has it ticked, thus making me unable to Enable Accurate Multiplication…

Oh ops, I was on mobile didn’t see it :stuck_out_tongue:

Since you are on a laptop with two GPUs, you will need to check in Radeon settings for “Switchable Graphics” to make Citra use the AMD GPU instead of Intel HD. i5-2410M’s iGPU doesn’t support OpenGL 3.3 so if Citra is trying to use it that would be why. But yeah, check Radeon settings, or I guess since this is a very old GPU it might still be Catalyst Control Center :stuck_out_tongue:

Though other ways it can crash is having Disk Shader Cache enabled, but the latest log says you already have it off so it’s not that. In some cases some controllers can crash Citra so if you have any connected try unplug them.


But I think there is still some driver issue, when you updated the drivers(I assume for Radeon) did you install the Crimson Beta driver? If not you should do that.

Download Crimson Edition 16.2.1 Beta drivers from: https://www.amd.com/fr/support/graphics/amd-radeon-hd/amd-radeon-hd-6000m-series/amd-radeon-hd-6730m

But before you install, it’s recommended to run DDU first to wipe the old driver: https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

Thanks a lot !!! I’ll try this.

I did have a DS3 controller plugged in, should I terminate the SCP DS3 service too maybe ?
What about a wireless keyboard?

I’ll report back when I’ve wiped the driver and updated

Thanks.
After a wipe and fresh install it finally ran.
I got a few freezes (had to end the process) in the Canary, but it ran better in the Nightly for some reason.

However it is indeed very slow, and given my HW, do you reckon there’s anything I can do?

I can emulate PS2 quite flawlessly and the weird thing is, it seems slower when there are 2D objects drawn than when there’s straight 3D. Perf oscillated between 8-20 fps.

If it’s indeed my HW limitations, feel free to close the subject and consider it solved.

Thanks a lot for your help !

Here’s the log for good measure.

Can you recommend any games that don’t need high ressources to run well maybe?

See ya

citra_log.txt (65.2 KB)

System Information for Support

Client Version                                Nightly 1458 HEAD-680ef64
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon HD 6700M Series
OpenGL Version                                3.3.1
GPU Driver Version                            15.301.1901.0
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hmm; guess I have my answer… This PC served me well but I think it’s time I upgraded.

Thanks again for your assistance!

Yeah 3DS is more difficult to emulate. I struggle even with a i7-3770K overclocked to 4.3GHz with a GTX 1070 in some games.

Ryzen 5 3600 with a GTX 1650 Super would do you nicely.