OpenGL 3.3 not supported? - NVIDIA GeForce RTX 2060

Issue:
As far as I know, my laptop’s specs should be fully within the parameters to run Citra. However, loading any game results in the following error: “Your GPU may not support OpenGL 3.3, or you do not have the latest graphics driver.” My GPU drivers are up to date and OpenGL Extensions viewer reports that I have OpenGL 4.1, so I’m not sure why I can’t run anything.

System Information

  • Operating System: Windows 10 Home Version 10.0.19042 Build 19042
  • CPU: Intel Core i7-10750H
  • GPU: NVIDIA GeForce RTX 2060
  • Citra Version (found in title bar): Citra Nightly 1695
  • Game: Story of Seasons
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (9.1 KB)

I also sometime get this error.I restart the pc and then it works :slightly_smiling_face:

Please double check that your monitor is plugged into your graphics card and not your motherboard.

I’ve tried restarting, but unfortunately that doesn’t seem to fix the issue.

I have a laptop, so I’m not sure what you mean by this. I have tried to set the NVIDIA as the default graphics card for Citra but that didn’t seem to help either.

@ank - Do you have the latest GPU Driver 461.92.
https://www.nvidia.com/Download/driverResults.aspx/171475/en-us
If you have then, I think that Citra it use Intel® UHD Graphics and not NVIDIA GeForce RTX 2060.

Intel laptop/prebuilt users with old driver versions will have to follow this video tutorial: https://www.youtube.com/watch?v=BZG50Nm5sOM&t=72s

I was finally able to resolve this, thank you everyone for your suggestions. For whatever reason, I wasn’t able to force the laptop to run Citra using the NVIDIA graphics card (it kept defaulting to the integrated one). I had already tried through NVIDIA’s software and through Windows, but neither had worked for me until I did the steps below.
I’ll document my process here in case anyone has the same issue, although you may not need all of the steps to get it to work:
Note- My laptop is an MSI GE75 Raider 10SE-008.

  1. I uninstalled all NVIDIA software and drivers from my PC (even though I had all of the latest ones).
    To uninstall software, go to Control Panel > Uninstall a program > Select everything that begins with NVIDIA and uninstall it (you may be prompted to restart your computer several times)
    To uninstall drivers, go to Device Manager > Display Adapters > Right Click over NVIDIA card > Uninstall

  2. I then went to my laptop manufacturer’s website (MSI USA) to see if any drivers have been updated since I last installed them. Only the ‘Intel Chipset Driver’ was updated, so I installed that. Then I installed the ‘NVIDIA Graphics Driver’ from the same place (as of current writing, it was version 442.23). During the graphics driver installation, I was prompted for either ‘Express Installation’ or ‘Custom Installation’. I selected ‘Custom Installation’ and made sure to check the ‘Perform a clean installation’ box.

  3. After doing all of this and restarting my computer, I opened up the NVIDIA control panel and went to Manage 3D Settings > Program Settings > Add, then added citra-qt.exe and citra.exe, making sure to select the ‘High-performance NVIDIA processor’ in the ‘2. Select the preferred graphics processor for this program:’ option. I didn’t change any settings for ‘3.’.

  4. Now in the NVIDIA Control Panel I went to Desktop > Display GPU Activity Icon in the Notification Area and made sure that was checked. I then opened this from the Windows tray. Here is what the icon and the Activity panel should look like:

  5. If everything is reset correctly, Citra should show up here if it is using the NVIDIA GPU, if it doesn’t then you may have to reinstall or update a different driver/program. It did not show up for me in here originally, until I followed the above steps, even though I had all of the same settings enabled.
    image

Note: After following the steps, I was able to update to NVIDIA’s latest driver (465.89) via their website (Download Drivers | NVIDIA) and everything is still working for me!

Here is a screenshot of the game working for me! :slight_smile:

1 Like

You should try Yuzu next with STORY OF SEASONS: Friends of Mineral Town and Animal Crossing.