OpenGL 4.3 not supported (but should be)

Issue:
I get a repeating “OpenGL not supported” type message, but I’ve gone through and updated my drivers and also checked - my NVIDIA definitely supports to OpenGL 4.6 - the Intel 630 GPU doesn’t to my knowledge but … that’s what the other one is for. So
I’m confused if I’m just missing something obvious here - I’ve gone through multiple builds, and even went back to 1700 just to see if any would work, but nope. Nothing changes.

System Information

  • Operating System: Windows 10
  • CPU: Intel(R) Core™ i5-9400 CPU @ 2.90GHz
  • GPU: NVIDIA GeForce RTX 2060 // Intel(R) UHD Graphics 630
  • Citra Version (found in title bar): Citra Canary 1794
  • Game: Pokémon Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (5.7 KB)

System Information for Support

Client Version                               Canary 2292   HEAD-3fe9ac1
Operating System                             Windows 10 Version 1909
CPU                                          Intel(R) Core(TM) i5-9400 CPU @ 2.90GHz | AVX2 | FMA
Graphics API                                 Unknown (?)
Graphics Renderer                            ?
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Since this appears to be a desktop system. Please take a look at the back of your PC to see whether your display is connected to your GPU, or your motherboard. If it’s connected to your motherboard, it will try to use your integrated GPU (the Intel HD 630). If it’s connected to your GPU, it will try to use your RTX 2060. Once we know this, we can troubleshoot more accurately.

Here’s a picture for reference:

Copy that - I’ll see about getting that then.
I’ve gone out of my way to disable my Intel GPU too if that helps and it hasn’t seemed to help. I’m not too computer savvy so I’ll be a minute while I try to figure out how to interpret the pic that was sent.

I think the issue is the emulator is not detecting the graphic card drivers from Nvidia? also I thank your version of windows 10 is outdated (Operating System Windows 10 Version 1909) it should be “21H2”

Yes, which is why I told them to check what their Display is connected to. This isn’t a laptop so it shouldn’t be switching between GPUs like what would sometimes happen on those devices.