OpenGL3.3 Error

#1

Issue:
The error “Your GPU may not support OpenGL 3.3, or you do not have the latest graphics driver” shows up when I try to play Pokemon X on my Mac, while I believe that my graphic card supports up to GL4.1 and I have updated my software to the latest version.

System Information

  • Operating System: macOS High Sierra 10.13.6
  • CPU: Intel Core i5 1.8 GHz
  • GPU: Intel HD Graphics 6000 1536 MB
  • Citra Version (found in title bar): Nightly 1180
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (14.7 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

This is a known issue, you can try the citra builds mentioned here. you may have to update your OS to the latest version available.

#4

How can I try the build?

#5

You can find canary and nightly builds here and here

#6

Which version of nightly am I supposed to use? The ones in the forum you mentioned doesn’t seem to support Pokemon X…

#7

This issue has been affecting Macs under High Sierra for almost 2 months now… From what I gathered from the Discord server the Qt library got updated and completely broke compatibility with older MacOS versions.

#8

So…is there no solution currently? (My MacOS is the most updated version and this still happens)

#9

You can try running Citra through your terminal in the meantime, depending on the builds you installed
cd /Application/Citra/[nightly or canary]/citra
/Application/Citra/[nightly or canary]/citra [ROM location/ROM name.3ds]

Prefs can be changed in SDL2-config.ini usually located in ~/.config/Citra-emu

#10

theres only one currently active dev that uses mac and they have been afk dealing with real life stuff. not much anyone else can do about it unless they have a mac to test it.