Own custom texture and textures from pack won't work together

I was trying to add a custom texture of my own to Shin Megami Tensei 4 Apocalypse since the HD texture pack that exists for the game isn’t fully completed. The custom texture I made wouldn’t load, I searched for the issue and saw on Reddit that you have to put the json file in the custom texture load folder. So I did that and it made the custom texture I made load, but it caused the custom textures from the HD texture pack to stop loading instead. Is there an easy way to get them to work together?

System Information

  • Operating System: Windows 10 Home
  • CPU: Intel Core i5-10400
  • GPU: NVIDIA GeForce RTX 2060
  • Citra Version (found in title bar): Citra Nightly 1940
  • Game: Shin Megami Tensei IV Apocalypse
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (95.4 KB)

We changed our Texture hash to a new format, older packs get loaded through a legacy mode, but if you want to add new textures to an old pack, you would need to convert it first to the new format. Using this tool:

Here is the Guide to use that tool:

So since the custom texture implementation has changed as of Nightly 1891 and Canary 2461 (due to a new hash format), you may find that adding to your existing texture packs is not working as intended. This tool is designed to convert old texture packs to the new format. You’ll need to redump all the textures that you wish to convert in order to map the old textures to the new format.


  1. Download the exe or build from source to the OS equivalent for your device.
  2. Open the command line and navigate to where you saved the exe/build
  3. In the command line enter the name of the tool: citra-pack-convert
  4. Afterwards you’ll need to enter 3 paramaters:
    This is the filepath for where your new dumped textures are located
    This is the filepath where your old dumped textures are located
    This is the filepath where you want the newly mapped textures to be saved to.
  5. Enter those parameters and run the tool, you should see all your existing textures mapped to the new format. If you see copy errors, don’t worry. These just mean that the newly dumped textures can’t find a corresponding old texture to map to (likely because they don’t exist in the pack).


citra-pack-convert C:\Users\User\Downloads\Emulator\user\dump\textures\00040000000EC400 C:\Users\User\Downloads\Emulator\user\load\textures\00040000000EC400 C:\Users\User\Downloads\Emulator\user\load\textures\00040000000EC400\new_mapping

Side note: In Windows specifically, if you have spaces in any of your folder names you must wrap the filepath in quotes or Windows will treat it as a seperate argument.

1 Like

Haven’t gotten to doing all the textures in the pack, but tried out some that I had dumped already and it worked! Thank you!