Performance Improvements (please help)

New to this, sorry if this thread wasnt done correctly, but im having trouble getting this game to run well. I have a decent computer (in my opinion) but i have no idea how to fix the performance. The game runs at 20% speed and around 6 FPS (Native resolution). I dont seem to have the option to use “Limit Framrate” or the ability to use my GPU. Can someone offer me tips? Even if AMD isnt suppported, I dont feel like it should run this bad. Any tips/other emulators i can use??

System Information

  • Operating System: windows 10 64 bit
  • CPU: Ryzen 5 1600x
  • GPU: AMD RX 580
  • Citra Version (found in title bar): Canary Build - fecdb7e/Nightly Build - 57aa18f (tried both)
  • Game: Pokemon Sun

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (13.8 KB)

System Information for Support

Client Version                                Canary 1750 HEAD-fecdb7e
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 1600 Six-Core Processor            
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            20.4.2 26.20.15029.27016
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • LLE Audio is designed for debugging purposes. Using this option will slow down your game. Try changing to HLE audio.

Dam, it was the LLE audio, I can’t believe it dropped the speed to 20%. I’d still like to know why I can’t chose my gpu or the “limit frame rate” option. I don’t have them at all