Periodic micro-freezes in a several games

Issue:
I have periodic micro-freezes in all games that I played: Mario 3D Land, A Link Between Worlds, Ocarina of Time. A Link Between Worlds may freeze forever, especially in cutscenes. I tried to change many settings, but the result is the same.
Or is the emulator unable to deliver smooth gameplay right now? Don’t feel like playing 240p on a small screen on 3DS :frowning:. I thought this would work great on my config

System Information

  • Operating System: Windows 10 Pro (20H2, 19042.804)
  • CPU: AMD Ryzen 9 3900X
  • GPU: RTX 2060 Super
  • RAM: 32 GB 3200 MHz
  • Citra Version (found in title bar): 1695

Diagnostic Log
citra_log.txt (681.4 KB)

System Information for Support

Client Version                                Nightly 1695 HEAD-c2d36cd
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 9 3900X 12-Core Processor            
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2060 SUPER/PCIe/SSE2
GPU Driver Version                            461.40
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

Pretty much, currently it is not really possible having buttery smooth, perfect frame pacing 24/7. Though I’m a bit surprised you said even Ocarina of Time 3D had issues while playing. I played it through fairly recently (2 weeks ago) on a laptop with i7-4710MQ & GeForce 840M with no issues; I didn’t feel any interruptions like freezes.

You might need to let the shader cache to be built a bit more which would help against some of these.

It’s weird, but all the freezes went away when I disabled the shader cache. Cashes are on SSD. Now sometimes FPS drops, but this is much better than when there were half-second freezes. I think there are performance issues in the hashing/search algorithm.

1 Like