Persona Q - Hangs on "Check for Add-On Content"

Issue:
When Persona Q starts to load its main menu, it hangs on the “Checking for Add-On Content” screen - it’s constantly scanning for something - the music and animation still happen in the background, but it’s just not advancing. Tried clearing all save data/extra data manually, using a recent version of Canary, but it still happens. I do have the system fonts/archive thing installed properly, as some games that wouldn’t work without it now work after I followed the procedure

System Information

  • Operating System: Win10x64 LTSB
  • CPU: Ryzen 2600x
  • GPU: RX 580
  • Citra Version (found in title bar): Canary 960
  • Game: Persona Q
  • Screenshot of Issue (include the full Citra window including titlebar):
    https://imgur.com/EN1YNLw

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide: citra_log.txt (39.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Likely a problem with the DLC. open the folder:
C:\Users\%username%\AppData\Roaming\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title\0004008c
move the folder 00123400, which is the DLC folder for your Persona Q region.
Redump your DLC, and reinstall it, make sure that you are using the latest version of godmode9.

Wow, those were really specific and very helpful instructions. Thank you!

I tried renaming that folder and citra got past the “Add On” screen no problem! Looking at the contents of the folder, I saw “One of them was not like the rest”, that being a 00000001.TMD file amidst a bunch of .app files which I assumed were the actual files for the DLC. I tried moving that TMD file, restarted Citra, and it loaded again - with Orpheus Telos in my compendium! (a DLC character) So I think it’s all working, now. (Too lazy to redump DLC anyway) Thanks!

Excuse me, Just for clarification, where do I move what?

What do i rename the folder to

Try just adding a single letter to the end of the folder name.

Which folder sorry, This is really my first go with emulation

Hey, no problem, we all start somewhere. Just to be sure though, you’re having the exact same symptoms as I had before? With Persona Q already installed and hanging on the “Checking for Add-On Content” screen?

The folder that I renamed was the folder “00123400” the location for which bio3c specified in his comment. I think at the time I just renamed it, “a00123400” or something. It was a while back.

1 Like

Yeah it’s the same problem. I’ll try that

Alright so it stopped the whole issue with the eternally loading add on content, but now the dlc just doesn’t show up

Unfortunately I can’t help you there - you’ll have to follow the guide to re-dumping your DLC that bio3c posted. I just decided that the DLC wasn’t that important to me and played the game without it.

Or, maybe you can try restoring the original name of the “00123400” folder and deleting or moving to the desktop one file within that folder at a time and reloading the game in Citra after every change to see if there’s a problem with one of the files that might be causing the hangups with the game. I’m not really sure that’s how it works, but that’s all we can address in this thread, to keep it on topic. Best of luck!

Just for reference, where is the 00000000.tmd file supposed to be

I don’t remember. Try just moving it to your desktop and restarting Citra.

I’m confused, I don’t have that file, I’ve checked everywhere

Oh wait nvm I just found it