Persona Q2 keeps getting load hangs/freezes

Issue:
At various points of the game, it would get stuck at various loading moments(during dialogue cutscenes, gameplay, menu ect.) The game essentially hangs, things like idle animations still plays and menu is technically operable, but when loading stuff(like character model loading in during cutscenes or going to the Shop or passing through a door in a labyrinth would hand indefinitely. Using load states can be attempted to dodge around it(works better with cutscenes, but not really when during battles). This can happen as early as during the starting menu cutscene.
A hallmark way to check if it will hang on the next loading is when opening the Menu, there’s no character sprite on the right side of the menu interface. Also, when checking Personas in the Menu or in the Velvet Room, their sprites would disappear/not appear when scrolling about. Then it would hangs when attempting to exit the Velvet Room.(it has a rather high chance to hang at the Velvet Room, somewhat)
Also, sometimes the game can freeze, and by that I mean the FPS drops to 0-1. But’s it happens in like 1/6th of the time.

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel(R) Core™ i3-6006U
  • GPU: Intel(R) HD Graphics 520 / NVIDIA GeForce 920MX
  • Citra Version (found in title bar): Intel(R) HD Graphics 520 / NVIDIA GeForce 920MX
  • Game: Persona Q2: New Cinema Labyrinth
  • Screenshot of Issue (include the full Citra window including titlebar):

    Example of a well, working Menu


    Examples of the hallmark glitch happening during Velvet Room and Menu(the Sprites are gone), and it will hangs during the next load

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (24.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

GL_VERSION: 4.3.0 NVIDIA 472.12
^ This driver is out of date. Please update to the latest GPU driver available for your GPU: GeForce Game Ready Driver | 531.41 | Windows 10 64-bit, Windows 11 | NVIDIA

Additionally, go to File>Open Citra Folder, then delete the shaders folder found here. Now try your game again.

Hm, still happens. I can’t tell if the frequency is the same or no. I even tried updating Citra

Please upload a new log file.

Here ya go, had to really loiter around in the Velvet Room to trigger it

citra_log.txt (18.9 KB)

Odd, it appears to be crashing on the streetpass service. Not sure why. Go to File>Open Citra Folder, then rename the nand folder found here to nand edit. Now try reproducing the issue again. If you can get it again, upload a new log file.

Here ya go. I noticed something after I renamed the “nand” to the “nand edit” folder. The actually speeds up after I increased the speed limit now
citra_log.txt (24.2 KB)

Hey there, I also have this issue. It seems to randomly hang when an animation or model needs to load in.
Has it been resolved yet?

citra_log.txt (188.0 KB)