Please help enable 4 players mode

Hi there :slight_smile:

I’m trying to play MK8D and/or MPS in 4 players mode. Yuzu main build 855.

My 4 joycons are apparently properly configured in Yuzu in the “controls” panel. All 4 are detected and I see the buttons light up on the panel when I interact with them. All 4 players are enabled too (4 green squares).

Now, when I launch MK8D, if I press L+R on the 1st joycon (player1) at the title screen, nothing happens. If I press L+R in any of the remaining 3 joycons, I get to the next menu but then none of the joycons are responsive (-> need to F5). I read somewhere that I needed to press L+R on the last joycon (player4) but that only leads to what I just mentioned above.

When I launch MPS, at the screen where I need to specify the number of players, when I select 2-4, the Yuzu “controls” panel (or some variation of it) appears. Since all the settings are already good, I just hit OK but then I’m back to the step where I need to select how many players will be playing (then the “controls” panel shows up again and I’m stuck in this loop). Pressing L+R on any of the joycons has 0 effect here…

I hope this is just me missing something obvious.

Thanks
-a-

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I read here and there that I should try Betterjoy.
Is this a good advice or is Betterjoy obsolete for current builds of Yuzu?

Is it only me having issues with 4 players mode or isn’t it a feature fully implemented in Yuzu yet?

Just tested on latest mainline. I did not have this issue at all. I was able to play with 4 players just fine. Could you update and try again?

1 Like

Thank you so much :slight_smile:

Do you mean Mainline Build - 32005200b from

?

I’m currently running MB 855

EDIT: Just updated to MB 867. Now it seems to work for MPS (could start the game in 4 players mode but havn’t tried to actually play it yet). However, it still doesn’t for MK8D (none of the joycons are responsive after pressing L+R on any of them).

I wonder if this has to do with the LED patterns on the Joycons.
AFAIU the LED should mean (when holding joycons horizontally with LEDs facing upwards) from left to right:

  • Player 1 / 2 / 3 / 4 for left (-) joycons
  • Player 4 / 3 / 2 / 1 for right (+) joycons

However, in my case it seems like the LEDs light up pretty randomly, even with 2 units sharing the same pattern.
Currently I have the following (according to what’s mapped in Yuzu controls panel):

  • Player1 : left (-) joycon, 2nd LED from the left (so “player2”??). “Nintendo Switch Joy-Con Left 0”
  • Player2 : right (+) joycon, 4th LED from the left (so “player1”??). “Nintendo Switch Joy-Con Right 0”
  • Player3 : left (-) joycon, 4th LED from the left (so “player4”??). “Nintendo Switch Joy-Con Left 1”
  • Player4 : right (+) joycon, 2nd LED from the left (so “player3”??). “Nintendo Switch Joy-Con Right 1”

Yuzu assigns a random led number, this has nothing to do with game failing.

I think I know your issue. When you map your controller you have two combo boxes. First one is the controller you are emulating and second one is the real device you want to map the input to.

Make sure to set the correct controller on the input device slot. The animated controller will show your inputs so you can test before going in game
image

1 Like

Yup I understood that.
When I said the joycons are maped correctly in the controls panel it means the animated image of the controllers reflects the input (for each 4 players).
For “Connect Controller” I set “Left Joycon” (for player 1 & player 3) or “Right Joycon” (for player 2 & player 4). For “Input Device” I set what I mentioned in my previous post (“Nintendo Switch Joy-Con Left 0” for P1 and so on…).

Now the fact that 4 players mode works for MPS but not for MK8D is quite puzzling to me…

Thanks again for your feedback, help and time. I appreciate it. Big time…
Best,
-a-

MK8D seems to work now :grinning_face_with_smiling_eyes:

I needed to reboot the PC multiple times and then make sure the joycons are ON before Yuzu is launched. if it doesn’t work, I need to do this again until it works.

problem solved!

Thanks to all you all :slight_smile: