PLEASE HELP! THANK YOU! Citra crashed when loading game(Pokemon X)

UPDATE: 8-3-2020
Hi, there, I understand this question is tricky… but anyone have any insight on it? thank you…

And I understand macOS user is rare… but…

Please… because switching OS account is really inconvenient…

UPDATE: 8-2-2020
On my MacBook, 15-inch, mid-2015, I switched to another account on my machine, it stop crashing and start functioning properly!

I have no idea how this work, but it worked!

I also learn from Apple Genius Bar the other day that when I create a new account on my machine, I actually have another new OS with no user data from previous using OS.

So, basically, I fixed my problem by switching to a new OS on my machine…

Although this is so inconvenient, because I have to switch between OS back and forth…

I tried to uninstall the Citra and removed ROM that crashed, and reinstall Citra and redownload the game ROM on my old OS, but it just keep crashing…

I don’t understand… is there anywhere I forgot to clean, system-wise? Otherwise, simply switching an OS shouldn’t fix problem…

Any idea?

Thanks!

PS, I feel so ashamed by myself, Citra is open sourced and I am a programmer as well, but I have no idea how to and where to debug… I am so suck…

Original Post:

Issue:
I am available to open the game at the first time but it crash when I try to restart game using Citra’s ‘restart’ from tool bar.

And the game can never be open again!

It keep crashing every time I loaded it.

System Information

  • Operating System: Mac OS Catalina (10.15.6)
  • CPU: 16 GB 1600 MHz DDR3
  • GPU: AMD Radeon R9 M370X 2 GB Intel Iris Pro 1536 MB
  • Citra Version (found in title bar): 1588
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt (4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Turn off Disk Shader Cache in the graphics settings in Citra. You might need to also turn off Hardware Shader in the Advanced tab.

1 Like

It works!!! Why??? I am so ashamed to ask this in technical detail given the fact that I am a programmer… and still, why?? There’s cache inside hardware from Citra??? Am I able to clean it? How??? Ok, maybe I should google it, right? Oh my god, THANK YOU!!!:laughing::laughing::laughing:

Oh, by the way, it works simply by turn off the Disk Shader Cache.

this is so awesome, man, thank you!!!

There is a bug with it if Accurate Multiplication is turned off, you can try enable that if you want to use Disk Shader Cache again but since you got the bug right now you will need to clear the cache by deleting the \shaders\opengl folder at ~/.local/share/citra-emu/

If you run into problems again just turn these settings off again.

God you are genius!!! Thank you thank you thank you!!!

And sorry for the late reply that I was checking the post yesterday while I was at work…

Anyway, thanks for the great advice!!!

I hope I will be able to help solving the bug… although I don’t where to start… I’m more familiar with web tech stack… what kind of prerequisite for reading the citra project code and provide contribution?

Ok… I know I should just google that… sorry… anyway, thank you!!! thank you a lot!!!

1 Like