Please make something for luigi's mansion dark moon

Issue:
hello, in the first level, the first ghost in the bathroom, when we try to capture it, the game crash. In the citra log , we can see a opengl error , but i use the last version :4.6 and my Nvidia driver is update too. I know it’s a bug known to people who want to play luigi’s mansion dark moon, so I wondered if the citra team was doing, or could do anything to fix this bug ( please patch this or find a solution :cry:)

thank you

System Information

  • Operating System: win 10
  • CPU: i5 6400 (3.2 GHz)
  • GPU: msi gtx 1050 2 Go
  • Citra Version (found in title bar): unnoficial build , but same crash on last nightly and canary
  • Game: Luigi’s Mansion Dark Moon
  • Screenshot of Issue (include the full Citra window including titlebar):
    https://youtu.be/fUaJ_PUPUWA?t=537

Diagnostic Logcitra_log.txt (496.8 KB)

Yeah it has been reported here: https://github.com/citra-emu/citra/issues/3984

Yes I saw this topic but it’s not the same error, look the log , my error is only openGL ( i’ve the critical error filter active) and i’ts not the same issue

if not, is there a way to patch or avoid this bug?

No way currently, I guess you can finish that part on your 3DS then transfer the save back.

dump the game can solve the probleme ?

You already did that though? You can redo it to make sure it’s clean.

Your log is also set to *:Critical change it to *:Info


why change log to *Info ?

To get more information.

ok, and what do I do once I have them?citra_log.txt (466.9 KB)

System Information for Support

OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 1050/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            436.15
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Sorry for the late answer, you will have to wait for when the crash has been resolved. It will either be solved by “accident”(by something not specifically for this crash) or when a developer sits down with the game and actively try to fix it.

Ok, thank you men, i think i ve find the probleme but i sreach a c++ dev to patch it