Plz help always low fps while playing kh:ddd

Issue:
Seems no matter what build, settings, or fixes i try i can not for the life of me get kingdom hearts : dream drop distance to run at an acceptable fps.

No matter what it’s like always 7fps while runnin around in game.
Weird thing is no matter how far past native resolution i set the emulator the fps stays exactly the same, and seeing how good the game could look it’s hard for me to justify playing the copy i have for my 3ds.

I have heard there is some problems using amd with opengl?
i also heard that those problems had been recently resolved by an amd update, but idk, my fps is still so bad.

Whatever is going on i feel like i’m so close, like something small could be changed, and i should suddenly get totally acceptable frames.

At this point iv put enough time tinkering away at it that i just felt like i should come and ask you guys.

Thank you all for your time.

System Information

  • Operating System: w10

  • CPU: AMD Athlon II X4

  • GPU: AMD Radeon 7900 series

  • Citra Version (found in title bar): I have tried many versions, mostly been testing with most recent build, both nightly and canary as of writing this.

  • Game: Kingdom Hearts : Dream Drop Distance

  • Log: citra_log.txt (47.1 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1415 HEAD-eb0364d
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon HD 7900 Series
OpenGL Version                                3.3.1
GPU Driver Version                            20.1.4 26.20.15017.1005
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [ ]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.